CCM integration for conferences: need multiple rooms

Good day,

We are attempting to use trixbox v2.8.0.4 to host the static conferences for our Cisco CallManager v7.1.2. This was previously configured and running on trixbox by my predecessor, unfortunately we had a bad power situation and when we brought the trixbox back up the functionality was gone. When we dialed the conference it asks for a pin, but hung up after the correct pin is entered. After performing a ton of research and trying multiple fixes I decided to try a fresh trixbox build to see if that would work. With the 2.8 build the issue is that no matter which of the 10 conference rooms is dialed the caller is required to enter the pin for the first room and is subsequently directed there.

I am quite new to Linux and Asterisk, but here are the settings which are configured on the 2.8 fresh build, I’m sure I’m just missing something simple. This is a closed network with no internet access and is purely CCM/CME voip. Any guidance you could provide on how to restore this functionality would be very appreciated.

On the CCM, which directs calls to a Cisco 3845 running CME. The CME then directs the calls to Asterisk:

SIP trunk
Name: Trixbox2
Call Classification: OnNet
Destination Port: 5060
SIP Trunk Security: Non Secure SIP Trunk Profile
SIP Profile: Standard SIP profile
Other than the IP of the CME, the name, and the description all other settings are default.

Route Pattern
Route Pattern: 88XXX
Gateway: Trixbox2
Call Classification: OffNet

The trixbox 2.8 is a fresh install with default settings other than the following (all which I copied from the old 2.6 build)

Conference rooms 88000 - 88009 created with the GUI
All rooms have a user pin and the User Count, User join/leave, and MoH set to yes.
Default inbound route: All settings default except destination set to Conferences (with the 88000 room showing).

Here is a snippet from the some configs:


include => ext-meetme-custom
exten => STARTMEETME,n,Hangup
exten => h,1,Hangup
exten => 88001,1,Macro(user-callerid,)
exten => 88001,n,Set(MEETME_ROOMNUM=88001)
exten => 88001,n,GotoIf($["${DIALSTATUS}" = “ANSWER”]?READPIN)
exten => 88001,n,Answer
exten => 88001,n,Wait(1)
exten => 88001,n,Set(PINCOUNT=0)
exten => 88001,n(READPIN),Read(PIN,enter-conf-pin-number,)
exten => 88001,n,GotoIf($[x${PIN} = x9245]?USER)
exten => 88001,n,Set(PINCOUNT=$[${PINCOUNT}+1])
exten => 88001,n,GotoIf($[${PINCOUNT}>3]?h)
exten => 88001,n,Playback(conf-invalidpin)
exten => 88001,n,Goto(READPIN)
exten => 88001,n(USER),Set(MEETME_OPTS=cIM)
exten => 88001,n,Goto(STARTMEETME,1)
exten => 88001,hint,MeetMe:88001


conf => 88000,9900
conf => 88001,9245
conf => 88002,1351
conf => 88003,2618
conf => 88004,3796
conf => 88005,1348
conf => 88006,4927
conf => 88007,4235
conf => 88008,7294
conf => 88009,7391

The dial-peer in the CME is:

dial-peer voice 88000 voip
description Trixbox Conference
destination-pattern 88…
voice-class codec 1
session protocol sipv2
session target:(ip of trixbox)
dtmf-relay rtp-nte

If more information is required I will gladly provide it.


Hi Jared,
I would do three things:
Verify your voice class codec includes g711ulaw/alaw if u dont have g729 installed.
Run asterisk -Rgcvvvvvvvvv and place a call also turn on sip debug in asterisk
Verify if conference works locally, most of the time when it does not work is a missing dahdi driver in Asterisk.