CAPI - Incoming Calls OK, outgoing not working properly


#1

I’m using a BT Speedway ISDN card which is an AVM!Fritz clone. After much hassle I finally managed to get the AVM!Fritz CAPI drivers installed and working on Fedora Core 3. Despite unloading the hisax package which appears to be mutually exclusive with fcpci, it keeps being installed on reboot. Anyone got any idea why? One post I found somewhere says that kudzu loads stuff and to remove it, however there’s a dependency with kernel-utils and I thought I might run into problems removing these packages. I eventually put a “rmmod hisax_fcpcipnp” into the boot script to unload the module before trying to start fcpci.

Configuring CAPI for incoming and outgoing calls was relatively straight forward, I can happily receive calls from PSTN/POTS via CAPI, but if I try to call out the called number rings OK at their end, but no sound is heard at the local end and when the called number answers no speech path is connected.

On dialling I get:-

    -- Executing Dial("SIP/ChrisMacneill-9f62",  CAPI/470xxx:07801xxxxxx") in new stack
    -- Called 470xxx:07801xxxxxx

On hangup at the local end I get:-

    -- CAPI[contr1/470xxx]/3 answered SIP/ChrisMacneill-9f62
  == Spawn extension (default, 07801xxxxxx, 1) exited non-zero on 'SIP/ChrisMacneill-9f62'

I have tried turning on capi debug, everything seems to proceed OK and masses of CAPI data is being transferred, the bridge just doesn’t seem to be made between CAPI and SIP. Is this a codec problem? The local hardware is a Grandstream 102 which works perfectly for SIP calls either locally or through a gateway.

capi.conf is default appart from changing the MSN value to suit the local ISDN line.

Snippet from extensions.conf

[globals]
TRUNK=CAPI/470xxx

[trunkld]
;
; Long distance context accessed through trunk
;
exten => _0Z.,1,Dial(${TRUNK}:${EXTEN})
exten => _0Z.,2,Congestion

Update…

After more searching I finally found come sample config files in the www.voip-info.org/wiki-Asterisk. Here’s the settings I found to work:-

exten => _0Z.,1,Answer
exten => _0Z.,2,Dial(${TRUNK}:b${EXTEN},90,rT)
exten => _0Z.,3,Congestion

I now get connected OK and the speech path is opened, but when the called party hangs up the call is not cleared. Any suggestions?


#2

I had the same problems running SuSe 9.3

Kernel version: 2.6.11.4-20a
chan_capi version: 0.3.5-5

The problem seems to be with this chan_capi version running on the kernel version mentioned above (a progamming defect which had was no problem with older linux kernels).

I solved the problem with downloading a newer version (source) from the developer site of chan_capi en rebuilding the chan_capi.so and the app_capi***

I’m now running with capi_chan version 0.5.3 without ANY problems. The sound is there with no change on the configuration files…

Try it…