Cannot register 2 sip channels

I am running Elastix v0.9.2 with * v1.4.17. Issue is I have two accounts with the same sip provider. I can register one account (either or), but I can not register both at the same time. When I try to activate (register) the second channel both channels drop off line with time outs, and the sip phones become unreachable as well…

Any one have any ideas?



Not all providers allow you to have multiple sip registrations with the same account

This is not multiple logins with a single account. This is two separate sip accounts. Can log in with only one at a time. With EasyVoxBox using asterisk 1.2 i can log both accounts in at once. With Elastix v0.9.2 using Asterisk 1.4.17, I can not…


Hi Mark

I have got the same thing on one of my trixbox boxes, but the stranger thing is, my test machine will do it fine.

I am suspecting it might be port forwarding on the router, but then why is it happy with one and not more???

I am probably going to replace the box with a temporary one and start it again, see if that helps.


I doubt it has to do with port forwarding as in using asterisk 1.4 on the Easyvoxbox v.10 i have no issues…both of the sip accounts will register…

I am thinking that somehow the asterisk 1.4.14 and greater are somehow corrupting the registrations if the is more than one…from what i gathered from my VoIP provider when I am trying to register both accounts from asterisk >1.4.14 they are receiving password is bad or wrong…

this is with no changes to my router or ports…


Interesting, but like I mentioned, I got my test box (running trixbox 2.4 = Asterisk 1.4.17) to work fine. I am working on it though, let you know what happens

Also, where in Aus?

am near wollongong…

so you have 2 VoIP accounts with the one provider and they both register???

Could you post your sip.conf and associated config files for me to gander at?? Might be something different there that I am doing or doing wrong…with the new Freepbx, there have been a ton of changes in the conf files…


I actually was having a similar issue with Vitelity. I tried registering with 2 accounts so I can use one for one outbound cid customization and one for a different outgoing display phone number. It was only using one of the numbers. So I figured this out.

Vitelity has one hostname people register with, but you will be assigned to one of about 11 IP addresses. So I registered one Vitelity trunk with one of their IP addresses, and the other trunk with the other address. It all worked.

Maybe you should ask your provider to give you 2 different IP addresses available to use.

The config is actually the same between the one that does work and the one that doesn’t.

I have to say, I think it is to do with how the network card is configured.

I configure it with the web-gui in either the trixbox console or webmin and it doesn’t work

If I use netconfig at the linux CLI, specifying all the values, it works :smiley:

I’ll send them to you if you like, which ones do you want?


I’m in Adelaide