Can not load sip and iax2 module


#1

I have a big problem. Until yesterday I had Asterisk 1.2.4 netsec running perfectly on FC4 for sip and iax calls, outgoing and incoming. Yesterday I had to install Oracle 10g Express Edition on this server. This went very well and Oracle is running. Asterisk was also running. We made and received calls during the rest of the day. Just before going home I remembered that I had Asterisk logging on debug to try to catch a diffiult time out problem for the audio of the meetme, “please dial the extension of the person…”, etc. audio. Since it’s been about a week and it did not happen again I decided to rever back to normal logging. So I editet /etc/asterisk/logger.conf and restarted Asterisk. Unfortunately I did not test the system after this change. Big mistake!

This morning I noticed that no phones could connect to Asterisk. I restarted, reverted back to full logging, restarted, recompiled, reinstalled and did everything imaginable (except to remove Oracle) to get the installation working again but could not solve the problem. So I made a copy of my configuration and removed /etc/asterisk, /usr/lib/asterisk, downloaded, recompiled and reinstalled zaptel 1.2.4, Asterisk 1.2.5 netsec, addons 1.2.2 and sounds 1.2.1. I tried this with Oracle running and with it stopped thinking that perhaps it took over some tcp or udp port (not very likely though).

However I still have the same problem. This is what happens:

Asterisk console:
Connected to Asterisk 1.2.5-netsec currently running on poirot (pid = 24411)
Verbosity is at least 3
poirotCLI> sip show peers
No such command ‘sip’ (type ‘help’ for help)
poirot
CLI> load chan_sip.so
Unable to load module chan_sip.so
poirot*CLI> load chan_iax2.so
Unable to load module chan_iax2.so

in the log file:
Mar 9 15:35:16 WARNING[24470] loader.c: /usr/lib/asterisk/modules/chan_sip.so: undefined symbol: ast_park_call
Mar 9 15:37:48 WARNING[24470] loader.c: /usr/lib/asterisk/modules/chan_iax2.so: undefined symbol: ast_park_call

Can anybody tell me what the problem might be?

Thanks a lot.


#2

I have the feeling that there may be a problem with the LD_LIBRARY_PATH variable. This is one of the variables that the Oracle environment script sets.


#3

The problem was solved by rebooting the server. I’m sure it can be solved without a reboot, but my time was running out. I really hate to reboot Unix/Linux servers.

In case anyone has this problem, Oracle 10g Express Edition does some strange things, so be prepared to reboot after installation.