Calls over the Internet vs LAN

Hi, I am new to Asterix . I have the following setup:

Asterisk/1.4.35
Asterisk GUI-version : SVN–rexported

I use the X lite 4 softphones in my scenario.

On my LAN I am able to make call and receive calls . Whether it is a wired client or wireless client it works.
Voice mail is working , email of my voice messages work fine. I have tried to get the Asterix to work over the Internet.
From a machine over the Internet I use my public IP not my IP of the asterix server. I am able to ring the softphones on my lan from across the internet but when I amswer I hear no voice . :frowning:
When I make a call to a softphone from my network to the Internet, the same result. I am able for the phone to ring but I hear no one.

I have a belkin Ni vision router and have port forward the following ports to my asterix server :
5060 - UDP
10001-20000 - UDP
4569 - UDP
5061- UDP

I have tried to place the asterix server in the belikin’s DMZ zone and experience the same result. :cry:

What am I missing ?

You also have to configure NAT on the Asterisk itself, so it includes the correct IP addresses in the SIP messages. Please search this forum or the web, you have tons on literature on this.

I have searched over the internet and came up with this

viewtopic.php?t=17191

the problem is this link says after you log in go to the file editor . How you do that in the GUI ?

I have made the entry in the sip conf file :

externip=x.x.x.x
localnet=192.168.1.0/255.255.255.0
nat=yes

Still the phone rings but no voice … next step troubleshoot ?

“rtp set debug on” to see where packets are coming from and going to.

Also, if the remote phone can be configured to use a stun server, try turning it on.

Ian

Hi,

I was able to change the setting on the phone X Lite 4 to discover public IP address (STUN) , it was orginally set to auto detect firewall traversal method using ICE ( recommended) . Still not working !! I was not able to choose a STUN server , I am using the free X Lite 4 softphone.

I am not sure how to set “rtp set debug on”. I have tried from the root using the comand rtp debug ip … do not work , I tried going to the /etc/asterisk and that also does not work.

Dont know what else to try !!

You have to enter “rtp set debug on” in the asterisk console. Enter asterisk -cr or -crvvv to connect to it. I’m sorry, I know nothing about the gui. Also, since I have never used 1.4 (why don’t you use the latest version?) the debug command might have changed since then.

Ian

Ian ,

I was running rtp set debug on from the console. Anyways, I did what you suggested and run the command asterisk -cr which then allowed me to run the command rtp debug ip 192.168.1.57 . This IP is the IP of the Asterisk server not the softphone client I presume.

What is the nest step now that this is enabled ? I am not sure where those logs are wriiten to ? I presume to try to make a call and then read some logs ?

PS: The new version was just not installing on my PC .

You need to make a call and watch the output in the CLI. You should see lines like:

Sent RTP packet to x.x.x.x:21000 (type 08, seq 022548, ts 016320, len 000160) Got RTP packet from x.x.x.x:21000 (type 08, seq 000076, ts 012160, len 000160) Sent RTP packet to x.x.x.x:21000 (type 08, seq 022549, ts 016480, len 000160) Got RTP packet from x.x.x.x:21000 (type 08, seq 000077, ts 012320, len 000160)

where x.x.x.x is the IP address that asterisk is receiving packets from trying to send packets to. If they are both the same and it’s the external address of the phone, then it’s not a NAT issue. If asterisk is trying to send to the wrong address, then it’s probably a NAT issue. If it’s one-way only, then it could be a firewall problem.

Ian

This is the output when making a call locally on my LAN that works !!

[color=#FF4000] – Executing [6001@DLPN_DialPlan1:1] Macro(“SIP/6005-00000021”, “stdexten|6001|SIP/6001&IAX2 /6001”) in new stack
– Executing [s@macro-stdexten:1] Set(“SIP/6005-00000021”, “__DYNAMIC_FEATURES=”) in new sta ck
– Executing [s@macro-stdexten:2] Set(“SIP/6005-00000021”, “ORIG_ARG1=6001”) in new stack
– Executing [s@macro-stdexten:3] GotoIf(“SIP/6005-00000021”, “0?6:4”) in new stack
– Goto (macro-stdexten,s,4)
– Executing [s@macro-stdexten:4] Dial(“SIP/6005-00000021”, “SIP/6001&IAX2/6001|20|”) in new stack
– Called 6001
[Apr 4 22:57:46] WARNING[11447]: app_dial.c:1298 dial_exec_full: Unable to create channel of ty pe ‘IAX2’ (cause 20 - Unknown)
– SIP/6001-00000022 is ringing
– SIP/6001-00000022 answered SIP/6005-00000021
– Packet2Packet bridging SIP/6005-00000021 and SIP/6001-00000022
== Spawn extension (macro-stdexten, s, 4) exited non-zero on ‘SIP/6005-00000021’ in macro ‘std exten’
== Spawn extension (DLPN_DialPlan1, 6001, 1) exited non-zero on ‘SIP/6005-00000021’[/color]

I will post the output when trying to make a call over the net tomorrow .

Thanks for the support so far.