Caller ID in Asterisk using Voxee VOIP not working!

Please help,

We have tried almost all possible combinations to make the Caller ID work for Voxee. Basically our plan is to use Voxee as our Trunk Line but it should send out our Japan phone number which is 0358517740. Anyway whatever settings we put out it basically gives us “Not Support” or “0” as a CID.

I got this configuration straight from Voxee Support.

exten => _1NXXNXXXXXX,1,Set(CALLERID(number)=2125551212)
; NOTE: The line below is required. It will not affect the Calling Name
; from displayed to the called party. If the called party subscribes to
; Calling Name service, the called party’s local exchange carrier performs
; a query to determine the Calling Name based on the Calling Number that is
; received with the call.
exten => _1NXXNXXXXXX,2,Set(CALLERID(name)=)
exten => _1NXXNXXXXXX,3,Dial,SIP/${EXTEN}@voxee
exten => _1NXXNXXXXXX,4,Hangup
exten => _011.,1,Set(CALLERID(number)=2125551212)
exten => _011.,2,Set(CALLERID(name)=)
exten => _011.,3,Dial,SIP/${EXTEN}@voxee
exten => _011.,4,Hangup

My Actual Configuration in Asterisk
exten => _011.,1,Set(CALLERID(number)=0358517740)
exten => _011.,2,Set(CALLERID(name)=)
exten => _011.,3,Dial,SIP/${EXTEN}@voxee
exten => _011.,4,Hangup

Any help would be appreciated!
Best regards,

in sip.conf or iax.conf, try adding fromuser=(yourdidnumber) to the voxee entry…

Hello IronHelix,

Thanks for your reply. Did what you said but no CID is displaying… Do you have any more ideas as to why It’s not displaying…

I’m really on a deepend right now and if anyone knows of an outgoing trunk line that might be able to provide a CID when you call. I’m all ears…


try setting the cid name too


the other possibility- 035 isnt a valid area code… perhaps voxee is doing some kind of sanity checking on the outbound caller id?

Thanks very much IronHelix, I’ll try your suggestion later.