Broadvoice Incoming - call is destroyed immediately


#1

I cannot get incoming calls to work, while outgoing works fine.

Broadvoice is registered, i have checked with them.

I am also getting the call inbound, but the call is immediately destroyed and never sent to an extension as you can see below, the all should be forwarded to extension 27.

I have noticed two different ways of registering broadvoice. On their site they have a complex way making seperate inbound and outbound contexts.

However, other inbound providers I just register and then use /ext to send the call to the right place. I dont understand why Broadvoice should be any different.

I have tried both ways, the simple way:
register => xxxxxxx@sip.broadvoice.com:mypassword:xxxxxx@sip.broadvoice.com/27

gives me no different result than using the broadvoice method. The call comes and is immediately destroyed.

Any ideas?

<-- SIP read from 147.135.32.128:5060:
ACK sip:27@xx.xxx.xx.xxx:5060 SIP/2.0
Call-ID: c702fe-c7@147.135.32.128
CSeq: 1 ACK
From: "xxxxx"sip:xxxxxx@147.135.32.128;user=phone;tag=prtv
To: "xxxxxxx"sip:27@xx.xxx.xx.xxx;user=phone;tag=as259892cf
Via: SIP/2.0/UDP 147.135.32.128:5060;received=xx.xxx.xx.xxx
Content-Length: 0

— (7 headers 0 lines)—
Destroying call 'c702fe-c7@147.135.32.128’
Apr 8 15:27:33 NOTICE[1441]: chan_sip.c:5237 sip_reregister: – Re-registration for xxxxxxxxx@sip.broadvoice.com@sip.broadvoice.com


#2

What do your sip.conf and extensions.conf files look like?


#3

SIP.conf

[general]
context=default ; Default context for incoming calls
bindport=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls
defaultexpirey=120

pedantic=no

;register => xx@sip.broadvoice.com:mypass:xx@147.135.32.128/27

register => xx:mypass@sip.broadvoice.com/27

[broadvoice]
type=friend
user=phone
host=sip.broadvoice.com
fromdomain=sip.broadvoice.com
fromuser=xx
secret=mypass
username=xx
insecure=very
context=default
authname=xx
dtmfmode=inband
dtmf=inband
;nat=yes
;Disable canreinvite if you are behind a NAT
canreinvite=no
qualify=yes

extensions.conf

[general]
static=yes
writeprotect=no
autofallthrough=yes
clearglobalvars=no
priorityjumping=no

[default]

exten => 27,1,Dial(SIP/27)
exten => _1NXXNXXXXXX,1,Dial(SIP/${EXTEN}@broadvoice,30)
exten => _011.,1,Dial(SIP/${EXTEN}@broadvoice,30)


#4

Hello,

I do see some differences in your configuration and mine (working in a@h – check out canreinvite for example); however, instead of bouncing back and forth a few times, here is my configuration:

I also setup sip.broadvoice.com to the nearest sip proxy in my hosts file.

Regsiter line: @sip.broadvoice.com::@sip.broadvoice.com

Outgoing settings: Trunk name: [Broadvoice]
authname=
canreinvite=no
context=from-pstn
dtmf=inband
dtmfmode=inband
fromdomain=sip.broadvoice.com
fromuser=
host=sip.broadvoice.com
insecure=very
qualify=yes
secret=
type=peer
user=phone
username=

[<phone number]
authname=
canreinvite=no
context=from-pstn
dtmf=inband
dtmfmode=inband
fromdomain=sip.broadvoice.com
fromuser=
host=sip.broadvoice.com
insecure=very
secret=
type=user
user=phone
username=


#5

How come some people use two context sections, one for incoming, and one for outgoing?

You have type=peer in one context and type=user in the other.

What is the difference?


#6

To accept incoming calls from broadvoice, put your assigned phone number in extensions.conf.

For example, assuming your phone number assigned by broadvoice is 7025551212:

EXTENSIONS.CONF

[default]

;Incoming Calls from Broadvoice dial the local ext “SIP/myext”.
exten => 7025551212,1, Dial(SIP/myext)

; Long distance dial out access through Broadvoice
exten => _1NXXNXXXXXX, 1, dial(SIP/${EXTEN}@sip.broadvoice.com,30)

SIP.CONF

[general]
register => 7025551212@sip.broadvoice.com:MypasWORd:7025551212@sip.broadvoice.com/719

[sip.broadvoice.com]
type=peer
host=sip.broadvoice.com
secret=MypasWORd
user=phone
fromuser=7025551212
username=7025551212
authname=7025551212
fromdomain=sip.broadvoice.com
context=default
insecure=very
canreinvite=no
dtmfmode=inband
dtmf=inband


#7

that was easy.

I did have to remove the extension from the registration line though:

SIP.CONF

[general]
register => 7025551212@sip.broadvoice.com:MypasWORd:7025551212@sip.broadvoice.com

(removed the /719)

although i did not do extensive testing and it may be that removing it was not necessary.

Thanks!