BroadVoice and "Time To Register"


#1

Alright, I’m back with another problem. My call forwarding isn’t working correctly on my 3 BroadVoice lines. The last four digits of the lines are 1026, 1027, and 1028. The way everything should work is that the first call should come in on 1026. If that line is busy it forwards to 1027. If that line is busy then it forwards to 1028. Unfortunately, that isn’t happening. BroadVoice is telling me to look for a setting called “Time to Register” and that I should set it to “3600 seconds”. Does anyone know where this mystical setting is located?


#2

There is a setting in sip.conf
defaultexpirey set this to 3600 (e.g: defaultexpirey=3600)
Try configuring this in your asterisk server. I am not sure if this will work. But it is worth a try.

Note: This setting however affects (sending REGISTER requests) all the phones that are registered to your asterisk server.

Hope this will solve your problem.
Seshu


#3

I actually just found that about an hour ago. I’m not sure if it took affect yet though, we’ll find out soon. There’s nowhere else I need to stick that, is there?

As to the name of that setting, since when is “expiry” spelled with a second “e”?


#4

Please post your results here so that it may help someone else who may have the same problem.

About the extra ‘e’ in the parameter name since it is open source and there are people from all over the globe contributing to * we can expect that . :smile:


#5

Well, after 24 hours (or so) it seems to be working correctly again. I don’t know if it’s registering correctly but I now have 7 incoming lines that fail over as they should (POTS->1026->1026 Call Waiting->1027->1027 Call Waiting->1028->1028 Call Waiting).

All I did was add the following to sip.conf right below the “allow” statements in the “[general]” section.

maxexpirey=3600 defaultexpirey=120