Behind NAT: RTP stream for 4-6 seconds then silence?


#1

I’m using both Xten Lite and Eyebeam, both behind NAT. My * server is sitting in a datacenter sans firewall. I’m experiencing two problems:

  1. Dialing into my voicemail using either softphone works just fine. SIP appears to be doing it’s job. I get connected to the VM prompt, but 4-6 seconds later the RTP stream just stops. Watching the CLI, I can see that the dialplan continues though. The same problem occurs when a PSTN call is bridged to my softphone. I can hear the person for only a few seconds before the sound dies; the call is still connected however.

Plugging my PC directly into the router, bypassing the NAt/firewall (WatchGuard SOHO6), things work perfectly.

  1. I installed Xten Lite on another PC on the same LAN as my first PC. Dialing extension-to-extension causes the call to be routed and setup fine. However, again, RTP is broken. Only this time I don’t get any sound at all, except for a couple of miliseconds worth every 30-60 seconds or so.

I’ve enabled/disabled reinvites, tried multiple codecs, and made sure that “nat=yes” in my sip.conf. I’m about out of ideas. Can anyone suggest anything? I have a Cisco 7960 sitting on my desk, but I’m still working with Cisco to try an get a SIP image.


#2

It sounds like some weird effect of the way that particular router/firewall works. It might be worth looking at its configuration options and seeing if there’s any possible way of configuring it so it works differently.

Alternatively, if possible, try using IAX instead of SIP.


#3

Thanks for the advice. After much grief (of an unrelated kind), I finally got the 7960 working. Getting it to function behind NAT was never an issue so now I have to figure out what’s wrong with the softphone config.