Background noise

I have called into my system from several different external landlines.
The voice prompts from the system are clear. No problems there.

But when I leave a voice message, there is static background noise.

How can I reduce or supress this background noise?

which format are you recording in?
If you are using gsm then try using wav.

I have not made any changes to default settings.

But when I look at the directory for my voice messages:

I see wav files:

total 736 drwx-w---- 2 asterisk asterisk 4096 Jul 20 03:02 . drwx-w---- 4 asterisk asterisk 4096 Jul 19 01:51 .. -rw------- 1 asterisk asterisk 250 Jul 20 03:02 msg0000.txt -rwx------ 1 asterisk asterisk 659564 Jul 20 03:02 msg0000.wav -rwx------ 1 asterisk asterisk 67010 Jul 20 03:02 msg0000.WAV

How do I change the format to gsm, if that is what I should do?

Use lame and convert them to 56 kbps mp3.
See if you find any difference in doing that.

That did not work.
I followed the syntax in the lame man page and the resulting mp3 file was inaudible.

try the correct options something like :-

lame -b 56 --resample 44.1 -m j --add-id3v2

Using lame to convert a file that already has background noise in it will not magically remove the background noise. In fact, doing any type of conversion on a file that sounds bad will likely make it sound worse.

Instead, edit your voicemail.conf file and change the preferred formats line. I don’t remember it exactly, but it is obvious when you view the file.



The “voicemail.conf” file:


98765 => 40898765,Common MailBox,,,attach=no|saycid=yes|envelope=yes|delete=no
76543 => 0076543,Bob,,,attach=no|saycid=yes|envelope=yes|delete=no
876321 => 09876543,Tom,,,attach=no|saycid=yes|envelope=yes|delete=no

The “” file:

; 1st listed format gets emailed

pbxskip=yes                     ; Don't put [PBX]: in the subject line
serveremail=vm@trixbox          ; Who the e-mail notification should appear to come from
fromstring=Voicemail System ; Real name of email sender
maxmessage=180                  ; max length of vm message
minmessage=3                            ; Minimum length of a voicemail message in seconds
maxsilence=5                    ; Wait for 5 silent seconds and end the voicemail
silencethreshold=128            ; What do we consider to be silence
skipms=3000                                     ; How many miliseconds to skip forward/back when rew/ff in message playback
review=yes                                      ; Allow sender to review/rerecord their message before saving it
operator=yes                            ; Allow caller to press 0
nextaftercmd=yes                        ; Automagically play next message when current message is deleted or saved

Should I change the “” file entry from:

Then restart asterisk?

Ok. I changed it to format=gsm
But I cannot play the message files any more.
I tried playing these files with mplayer and vlc.
They just exit immediately.

Interesting. You might try changing the line to:


Then see if you can play back the existing messages. Afterwards, perhaps change the option back to just gsm.



Using lame to convert a file that already has background noise in it will >> not magically remove the background noise

It has worked for me though. So I had suggested to try and see if
that works for him.
Lame has some options (low pass or high pass filter I am not sure).
see the link … index.html


The voicemail format in your previous settings were alright.
The GSM format gives compact sound files but you will have to compromise on the quality (so in your case more speech degradation).


OK. This made a big difference.
Before, the noise was distinct and noticeable.
Now, the voice message is distinct and noticeable.

There is still some noise there. But much less than before.
Do you have any more suggestions?
I can work on them.