Asterisk within WLAN only

Hi there,

I would like to install asterisk to let the PCs in our WLAN network to call each other using a softphone such as X-lite. But I do not want to use any trunk. I have tried but X-lite always reports the error number 408 SIP account can not be enabled.

Any help is appreciated.

408 it is request time out, make sure Asterisk is listening on the default SIP port ( UDP 5060), and that there is no firewall or iptables blocking the incoming traffic to the Asterisk server.

Thank you ambiorixg12!
Could you please tell me how to know whether Asterisk is listening on the UDP 5060 port?

netstat -apn | grep -i asterisk

It is also quite likely that you failed to open the firewall for port 5060 on the machine running Asterisk.

Thank you very much ambiorixg12 and david551!

I have managed to enable the port and make calls successfully now.