Asterisk to oracle 11 via unixodbc - any oracle help!


I thought I might share my experience about this issue here.

All posts are delivering very useful information. I think the setup described in previous post is correct. I am using CentOS 5.3 and the Asterisk

I did install the Oracle Instant Client The version won’t work out of the box as it requires unixODBC 2.2.12 - at least this is what I understood from other posts. I think the easiest was to use a lower version of the Oracle odbc to keep the system clean… I guess if yum update returns the latest version of the unixODBC, we could move to the latest version.

The most usefull debugging was the odbc trace. Enabled by adding:


to the /etc/odbcinst.ini.

I’ve been searching for hours, and always had problems regarding libraries:

Kept on checking all those libraries were fine. isql worked fine. sqlplus worked fine.

I haven’t cleared it out completely yet, but I suspect it has something to do with the way asterisk is launched through the service asterisk start command. When you launch the asterisk manually with the command safe_asterisk it will start working. Looks like the environment is missing when launching it with the service command.

I didn’t figure out yet why, but this is already a step forward, isn’t it?

Bye, BW.

hi, guys some all ready execute oracle stored procedure from func_odbc?
i have several weeks looking for this info… some body have a example?