Asterisk show 2 missed call instead of one


#1

Hi!
I had an issue while configuring my dialplan.
How it works for me:
incoming call is being translated to this context:

[inbound]
exten => 201,1,Log(NOTICE, Incoming call from ${CALLERID(all)})
exten => 201,2,Dial(SIP/201&SIP/202&SIP/204,5)
exten => 201,3,Dial(SIP/201&SIP/202&SIP/203&SIP/204&DAHDI/4)
exten => 201,n,Hangup()

and when someone picks up phone on 201 after 5 seconds, there’s 2 missed calls on other phones, instead of one.
I know, that it works exactly how i wrote it, but i just want to know, how can i add a few devices to first Dial step, instead of writing second one.

Regards,
Nufay.


#2

try the ‘c’ option to the first dial string.

exten => 201,2,Dial(SIP/201&SIP/202&SIP/204,5,c)


#3

I read about all options, there are similar parameters, but they are not what I need.
Option ‘c’ doesn’t solve my issue.


#4

It looks as though using 201 for the extension and a device may be causing the issue. Try changing the extension to something else and see if that fixes it.


#5

tried to change to 202 but that didn’t worked neither


#6

Use Local channel when Dialing

Here’s an example(Not tested!)

exten => 201,2,Dial(Local/201@local_dial&Local/202@local_dial&Local/203@local_dial&Local/204@local_dial&Local/4@local_dial)

[local_dial]
exten => _X.,1,ExecIf($[$[${EXTEN} = 203] | $[${EXTEN} = 4]]?Wait(5):NoOP())
same => n,ExecIf($[${EXTEN} = 4]?Dial(DAHDI/4):Dial(SIP/$(EXTEN))

–Satish Barot