Asterisk server not working with imsdroid


I am new to asterisk server. I have redhad enterprise linux server 5 with kernel 2.6.18-308.1.1.el5xen. I tried to install libpri, dahdi-linux-complete-2.5.0+2.5.0 and asterisk 1.8.5 from source. I successfully installed asterisk 1.8.5, but dahdi-linux-complete-2.5.0+2.5.0 i am not able to install since “make all” gives the error that “You do not appear to have the sources for the 2.6.18-308.1.1.el5xen kernel installed”, but i have installed the kernel-devel for this version and when i tried to install i get the message “Package kernel-devel-2.6.18-308.8.1.el5.x86_64 already installed and latest version”.

Asterisk is running without any problem. But i am not able to register with IMSDROID client from the android phone. Is it because dahdi-linux-complete is not installed, or due to some other reasons?

How to debug to find where is the problem? Please help me out, i am desperately need the solution and i have to make this work.


The kernel-devel part of your problem is that you have a later kernel installed than you boot loaders is actually loading. You either need to boot to the most recent kernel, or explicitly install the back version of the kernel-devel package.

Note. This was the wrong forum for a support question.