Asterisk OPTION packet?

Why asterisk writes to OPTION packets it’s local ip address? IP phone is in public ip side. Asterisk is another public ip side than the ip phone and under the nat. Here informations:

IP phone public ip:
Asterisk public ip:

No. Time Source Destination Protocol Length Info
1 0.000000 SIP 605 Request: OPTIONS sip:503@ |

Frame 1: 605 bytes on wire (4840 bits), 605 bytes captured (4840 bits)
Ethernet II, Src: Tp-LinkT_5f:6f:54 (10:fe:ed:5f:6f:54), Dst: 00:a8:59:d1:9e:b2 (00:a8:59:d1:9e:b2)
Internet Protocol Version 4, Src: (, Dst: (
User Datagram Protocol, Src Port: 5061 (5061), Dst Port: 5082 (5082)
Session Initiation Protocol (OPTIONS)
Request-Line: OPTIONS sip:503@ SIP/2.0
Message Header
Via: SIP/2.0/UDP;branch=z9hG4bK15c4adca
Max-Forwards: 70
From: “Unknown” ;tag=as703c69cf
SIP Display info: "Unknown"
SIP from address: sip:Unknown@
SIP from tag: as703c69cf
SIP to address: sip:503@
Contact URI: sip:Unknown@
Call-ID: 5388894072d99e7b34ed9ea15e508f8c@
User-Agent: FPBX-13.0.99(13.8.0)
Date: Thu, 30 Jun 2016 07:50:32 GMT
Supported: replaces, timer
Content-Length: 0

What channel driver is being used, and is it configured to know it is behind NAT?

chan_sip is driver.
which parameters do you mean?

In my configuration:

chan_sip has to be told in the general section using externip and localnet its public IP address, or else it won’t know to put it in messages.

Thanks friend. You know many valuable information about asterisk.

Now i have another issue.

I try TLS calling.
I have 2 sip clients and they are under different public ip addresses. And asterisk is under the another different public address. When i try to call from one client to another one, callee is hook-off but in caller phones shows that callee’s phone still ringing.(like latency). 10-15 seconds later hook-off message of callee arrive to caller. What is the reason for this delay? Still i get these messages.
[2016-06-30 15:25:27] NOTICE[5656]: chan_sip.c:29921 sip_poke_noanswer: Peer ‘502’ is now UNREACHABLE! Last qualify: 33
[2016-06-30 15:25:59] NOTICE[17295]: chan_sip.c:24403 handle_response_peerpoke: Peer ‘502’ is now Reachable. (355ms / 2000ms)
[2016-06-30 15:27:03] NOTICE[5656]: chan_sip.c:29921 sip_poke_noanswer: Peer ‘502’ is now UNREACHABLE! Last qualify: 355

But same scenario works well without TLS. I have tried without TLS soon before. There was not any delay.

With TLS:
Phone A is calling Phone B easily and without any delay.
Phone B is calling Phone A with constant delay. Phone A hooks-off phone but Phone B realize it after 30 seconds. I have tried 5 times. Everytime delay was 30 seconds.