Asterisk on vmware


#1

i try to run asterisk on vmware. after install i run asterisk -vvvgc and it failed.
it says that :[app_txfax.so][…] Ouch … error while writing audio data: : Broken pipe.
what 's wrong ? how to resovle it ?


#2

is there any way?


#3

You could try adding the following to modules.conf

noload => app_txfax.so

I don’t know if it will help or not, and i don’t know if you’re doing anything that needs that module…

I don’t seem to have app_txfax.so module in my version of asterisk though, so i may be way off the mark here.


#4

it works but when i use mp3player ,playback,meetme etc apps i will hear no voice from the softphone! how to deal with such a problem?


#5

I use VMware as well & had exactly the same problem.

It relates to the module ztdummy failing to load correctly because the VMware’s virtual USB hardware cannot supply a valid timing source.

The easiest resolution is to shutdown the virtual machine & then uninstall the USB hardware in the VMware virtual machine settings. On reboot, the Linux O/S will detect & reconfigure hardware changes.

The only downside to this workaround is that the meetme conference rooms no longer work. You will hear a message telling you that you have dialled into an invalid conference.

If anyone knows a workaround for this, then please enlighten us.


#6

i solve the problem :smile: .i download the code zaptelrtc code and build them .then i insmod zaprtc.o .in order to succeed to insmod zaortc.o you should modify the configuration of kernal using memuconfig .find the item Enhanced RTC in Character Devices .the default is enable you should disable it.them rebuild and install the kernel .succeed to rebuild the kernel you can use meetme apps and you can hear voice from softphone .