Asterisk not seeing Dadhi as inactive or line down

I have a really odd problem.
I have build asterisk on centos7.9 with dahdi using a TE420 card (5th gen).
I have tried asterisk 18 and 20 with and with dahdi drivers 2.9 2.8 3.2
Everything compiles fine without any issues and I can make calls in and out via the digium card, the issue is if I disable an E1 on our ISDN switch, asterisk doesn’t detect that the line is down, also if I run /etc/init.d/dadhi stop, asterisk still see’s the card as running.
Running service dahdi status shows the card as inactive yet asterisk still thinks its running.
running dahdi restart in the console, asterisk go’s through the process of restarting the card, reports the spans are up even though I have disabled card via init.d and it service status shows it as down.

I never come across this at all, I expect asterisk to show an alarm when I disable the E1 on our ISDN switch and asterisk complain that dahdi isn’t running.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.