Asterisk not registering with vonage


#1

Hello everyone. I have a vonage softphone and I’m trying to register to vonage using asterisk. I have not had any luck. I am behind a firewall. I’ve successfully gotten xlite to connect and work from the same network. When I change the port setting in [general] to 5061, I am able to register then, but all my other extensions cannot connect. I thought that specifying the port in the register string should be sufficient. Can someone please tell me what I’m doing wrong? Below is my sip configuration.

sip.conf:

[general]

port=5060 ; Port to bind to (SIP is 5060)
bindaddr=0.0.0.0 ; Address to bind to (all addresses on machine)
disallow=all
allow=ulaw
allow=alaw
allow=gsm
allow=g729
allow=g723

context=from-sip-external ; Send unknown SIP callers to this context
callerid=Unknown

register=1XXXXXXXXXX:PASSWORD@sphone.vopr.vonage.net:5061

[vonage]
username=1XXXXXXXXXX
type=friend
secret=PASSWORD
port=5061
nat=yes
host=sphone.vopr.vonage.net
fromuser=1XXXXXXXXXX
fromdomain=sphone.vopr.vonage.net
dtmfmode=rfc2833
auth=md5

[vonage_inbound]
username=1XXXXXXXXXX
type=friend
secret=PASSWORD
port=5061
nat=yes
insecure=very
host=sphone.vopr.vonage.net
fromuser=1XXXXXXXXXX
fromdomain=sphone.vopr.vonage.net
context=from-pstn
canreinvite=no
auth=md5
allow=all

==========
CLI> sip debug
:
:
:
Retransmitting #5 (no NAT):
REGISTER sip:sphone.vopr.vonage.net SIP/2.0
Via: SIP/2.0/UDP 192.168.1.10:5060;branch=z9hG4bK674c6ab6
From: sip:1XXXXXXXXXX@sphone.vopr.vonage.net;tag=as5c8219d8
To: sip:1XXXXXXXXXX@sphone.vopr.vonage.net
Call-ID: 2ba197c665043c8a08a6119e733083df@192.168.1.10
CSeq: 102 REGISTER
User-Agent: Asterisk PBX
Expires: 120
Contact: sip:s@192.168.1.10
Event: registration
Content-Length: 0

to 216.115.25.198:5061

==========

CLI> sip show registry
Host Username Refresh State
sphone.vopr.vonage.net:5061 1XXXXXXXXXX 120 Request Sent