Asterisk Manager Dial Error

Hi all,

I am trying manager interface, for some reason my voip calls fails with error Cause-txt: Unallocated (unassigned) number. Here is what I am doing.

[b]----Manager Client
Action: Originate
Channel: SIP/rapidvox
Exten: 12121231231 <-- Of course the real number goes here
Context: long_distance
Priority: 1

----sip.conf
[rapidvox]
type=peer
host=sip.rapidvox.com
username= myuser
secret= mypassword
fromuser=myuser
disallow=all
allow=ulaw
context=long_distance

[sip.zoiper2]
username= sip.zoiper2
secret=mypassword
context=long_distance
type=friend
host=dynamic

----extensions.conf
[long_distance]
exten => _1NXXNXXXXXX,1, DIAL, SIP/rapidvox/${EXTEN}
exten => 610,1,Dial(SIP/sip.zoiper2/${EXTEN})[/b]

From my registered softphone (sip.zoiper2), (which uses the same context ‘long_distance’), if I make a call to outside, it works fine. So I know my rapidvox configuration is alright.

Or If I issue this command in manager client to call my softphone

Action: Originate
Channel: SIP/sip.zoiper2
Context: long_distance
Exten: 610
Priority: 1

It successsfully rings my softphone so the dialplan should be ok too.

But when i try to call outside with the command

Action: Originate
Channel: SIP/rapidvox
Exten: 12121231231 <–Again i put real number here
Context: long_distance
Priority: 1

it fails as described.

Does anyone have any inputs? What am I missing here?

Thanks,

Vito

the “Channel” value of the Originate needs to be identical to what you would put in the Dial() command when trying to place a call over rapidvox. I have a feeling the cahnnel should look something more like

Channel: SIP/12121231231@rapidvox

with the Exten/Context/Priority being set to where you want the call to ‘land’ once it is started.

Interesting point. It worked !!! I checked my dialplan to see how I use the Dial command because i was not using ‘@’ and using SIP/rapidvox/${EXTEN} instead. So then I tried Originate command with channel being set to SIP/rapidvox/12321231231 and that worked as well.

Thank you very much