Asterisk log error message

This had 77 views and no one can tell me what this means. :neutral_face:

[2015-07-10 16:26:52] WARNING[1844]: chan_sip.c:4015 retrans_pkt: Retransmission timeout reached on transmission cd673e07ff01d16c249fa245d79f4697 for seqno 1 (Critical Response)

The wiki page would have immediately told you what it meant like I said on your original. It’s also been mentioned quite a lot in the past, be it here and in the mailing list.

As well - please don’t post again for the same thing.

I know that this is another cry for help about retransmission timeouts but that wasn’t very helpful for me jcolp. I am a type 5 so I hope my issue has nothing to do with NAT whatsoever.

I have started with a very basic setup based on the O’Reilly Asterisk book. Here are a few of the files (the only ones I have modified so far)
sip.conf

[general]

[1000]
type=friend
context=internal
host=dynamic

;[301]
;;demo extension for pfSense
;type=friend
;defaultuser=301
;insecure=port,invite
;secret=1234
;regexten=301
;host=dynamic
;context=default

;[302]
;;demo extension for pfSense
;type=friend
;defaultuser=302
;insecure=port,invite
;secret=1234
;regexten=302
;host=dynamic
;context=default

extensions.conf

[code][globals]

[general]
autofallthrough=yes

[default]

[incoming_calls]
exten => s,1,Answer()
same => n,Playback(tt-monkeys)
same => n,Hangup()

[internal]
exten => 7000,1,Verbose(1,Lets try weasels here)
same => n,Playback(tt-weasels)
same => n,Hangup()

[phones]
include => internal
[/code]

I get this if I use dialplan show at the CLI

Dialplan show
[ Context 'app_queue_gosub_virtual_context' created by 'app_queue' ]
  's' =>            1. NoOp()                                     [app_queue]

[ Context 'demo' created by 'pbx_lua' ]
  Alt. Switch =>    'Lua/'                                        [pbx_lua]

[ Context 'local' created by 'pbx_lua' ]
  Alt. Switch =>    'Lua/'                                        [pbx_lua]

[ Context 'parkedcalls' created by 'features' ]
  '700' =>          1. Park()                                     [features]

[ Context 'app_dial_gosub_virtual_context' created by 'app_dial' ]
  's' =>            1. NoOp()                                     [app_dial]

[ Context 'phones' created by 'pbx_config' ]
  Include =>        'internal'                                    [pbx_config]

[ Context 'internal' created by 'pbx_config' ]
  '7000' =>         1. Verbose(1,Lets try weasels here)           [pbx_config]
                    2. Playback(tt-weasels)                       [pbx_config]
                    3. Hangup()                                   [pbx_config]

[ Context 'incoming_calls' created by 'pbx_config' ]
  's' =>            1. Answer()                                   [pbx_config]
                    2. Playback(tt-monkeys)                       [pbx_config]
                    3. Hangup()                                   [pbx_config]

[ Context 'default' created by 'pbx_config' ]
  Alt. Switch =>    'Lua/'                                        [pbx_lua]

-= 5 extensions (9 priorities) in 9 contexts. =-

If I use sip show peers I get

sip show peers Name/username Host Dyn Forcerport ACL Port Status 1000/1000 10.200.0.21 D N 50713 Unmonitored 1 sip peers [Monitored: 0 online, 0 offline Unmonitored: 1 online, 0 offline]

I am using a Cisco 7960 phone. Is there anything else you all need to know?

CLI shows this when I test (the last bit about Retrasmission timeout takes a while… as expected?

    -- Executing [7000@internal:1] Verbose("SIP/1000-00000003", "1,Lets try weasels here") in new stack
 Lets try weasels here
    -- Executing [7000@internal:2] Playback("SIP/1000-00000003", "tt-weasels") in new stack
    -- <SIP/1000-00000003> Playing 'tt-weasels.gsm' (language 'en')
    -- Executing [7000@internal:3] Hangup("SIP/1000-00000003", "") in new stack
  == Spawn extension (internal, 7000, 3) exited non-zero on 'SIP/1000-00000003'
[Sep 12 18:01:43] WARNING[-1]: chan_sip.c:3821 retrans_pkt: Retransmission timeout reached on transmission 000d2858-8133000c-1cc4e445-307ac90a@10.200.0.21 for seqno 101 (Critical Response) -- See https://wiki.asterisk.org/wiki/display/AST/SIP+Retransmissions
Packet timed out after 31990ms with no response

I have tried setting reinvite=no as suggested at one of the millions of forums etc I have looked at these last few days. I have tried quite a few things…

I have a vague memory of loading another module in the pfsense version of asterisk from long ago. Does anyone know of that module or can suggest modules that may help?

Thanks all.

No module or anything is required. What you need to provide is the output of “sip set debug on” for a call attempt that fails and details of the network topology.