Asterisk listening port

Hi all;
i have a zycoo ip pbx (asterisk based), and i want to connect it to microsoft lync. when configuring lync to communicate with my ip pbx, the only option for listening port (5060) are tcp or tls. however, the ip pbx is only listening on udp port 5060. i tried to add tcpenable=yes tcpbindaddr=
to the general sip configuration, but after a reboot still the same issue
this is my sip.conf:

[general] language = en callerid = Unknown context = default bindport = 5060 bindaddr = tcpenable=yes tcpbindaddr= disallow = all allow = alaw,ulaw alwaysauthreject=yes defaultexpiry = 120 permit = allowguest = no allowtransfer = yes dtmfmode = auto maxcallbitrate = 384 maxexpiry = 3600 minexpiry = 60 t38pt_udptl = no qualify = yes allowsubscribe = yes subscribecontext = default notifybusy = yes notifyringing = yes notifyhold = yes limitonpeers = yes relaxdtmf = yes videosupport = yes

am i missing something to make it listening to tcp port 5060? Thanks


Contact the people that sold you something.


yes, i am waiting for their response…meanwhile, any suggestion will be really helpful…

You need an asterisk version with tcp support. My crystal ball says Zycoo is using version 1.4 and tcp support was added in 1.6 so you might be out of luck.

yep you’re right thor…i was obliged to put another 1.6 asterisk machine, and configure it as a gateway between lync and zycoo…