Asterisk is not sending data over HEP


I am using Asterisk 14.7.6 and I’m trying to integrate with HOMER to persist SIP traffic but no traffic is coming to the homer server.
I am using PJSIP instead of SIP. I have loaded the relevant modules for both PJSIP and HEP. I’m running Asterisk inside a docker container and homer is also running from another container. I have exposed all the relevant ports in homer (used the default docker-compose).

I have also enabled=yes in hep.conf and pointed it to (homer server running locally with default port as 9060)

CLI> module show like hep
Module                         Description                              Use Count  Status      Support Level                     HEPv3 API                                0          Running          extended               PJSIP HEPv3 Logger                       0          Running          extended                RTCP HEPv3 Logger                        0          Running          extended

As you can see, the Use count is 0.

I hope someone can help with this.

To point to, the containers must run with a network_mode = host in your docker-compose

@jcbru0560 Thanks for responding to my query. I tried with network_mode = host. It’s still not working.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.