Asterisk installation


I am new at installing asterisks and i am trying to install using trixbox 2.3 beta. I seem to have trouble installing the compiler gcc. i run the command yum install gcc and i get this error.
warning: rpmts_HdrfromFdno: Header V3 DSA signature: NOKEY, key ID e8562897

GPG key retrieval failed: [Errno 4} IOError: <urlopen error (111), ‘Connectin refused’)>

I’m hoping someone can help me, i really can’t fnd much on this.

Name of the OS you are using CentOs or Fedora ?

thank you for your reply, sorry i forgot about the OS, it’s CentOs.

you need to import the key
you can do this locally by running the command below
for centos 4 it would be

for centos 5 it would be

then run


good luck

I tried importing the key and got this error.
error: /usr/share/doc/centos-release-5/RPM-GPG-KEY*: import read failed (-1)
It is using Centos release 5 and i am logged in as root.

Try the below one …

normally the command

Will import the key for you automatically, try that and let us know