Asterisk install: sudo ./configure command error

Hi everyone I have the following problem while installing asterisk on Debian.
I’ve gotten to the point where I need to run the command: “sudo ./configure” I’m getting the following error:

“”""“root@debian:/usr/src/asterisk-18.11.1# sudo ./configure
checking build system type… x86_64-pc-linux-gnu
checking host system type… x86_64-pc-linux-gnu
checking for gcc… no
checking for cc… no
configure: error: in /usr/src/asterisk-18.11.1': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details

How can I fix it?

Please stop creating a post for each and every step where you encounter an issue. Just use a single thread.

first try

su -

if that work you need to fix your linux server
hint fix path in “/etc/sudoers”

If I don’t solve a step, I can’t go to the next step; so I don’t know if I will have problems in the next steps. This is logical if I disturb the community, I get out of the way. Are you the administrator?

I manage the forums and such. I’m not saying you can’t post here, just use a single thread and post in it as you encounter things. A post per issue is just excessive as you try to install things.

Forgive me but give me a solution tell me how would you do? You follow a guide at each step of the guide is there an error and you can’t go to the next step if you don’t solve the previous one first? Can you explain to me how I can write everything together if I don’t know going forward with the steps if the other errors will occur? You explain it to me so maybe you explain it to others too

You don’t need to write everything together all at once. If you encounter a new problem, you can just post in this same thread as you’re doing now.

ah ok now it’s clear but not before

So I go to the sudoers file and enter: $ PATH = / usr / src / asterisk-18.11.1? Unfortunately I am not very familiar with linux I did not think that at every step there was a problem :smile:

on your server if you do a
echo $PATH
is that the same as set in /etc/sudoers

also did it work if you use

su -
./contrib/scripts/install_prereq install
./configure --with-jansson-bundled

also have you installed an “acceptable C compiler”

just remember that using sudo is not the same as running as root

I am with the root user and in addition I put sudo on the command; when I execute “./contrib/scripts/install_prereq install” no error is returned to me the command executes it; But when I run “” ./configure --with-jansson-bundled “” The error “configure error” no acceptable C compiler fount in PATH is returned. When I type echo $ PATH it gives me the output: / usr / local / sbin: / usr / local / bin: / usr / bin: / sbin: / bin. The source unpacked it in / usr / src; However, I state that I have done all the Debian updates according to the guide but I always get this error.

If it really gave you that, it is no surprise that it doesn’t work. However, I think you have incorrectly copied what is actually there. This is what I get, after “su -”:

~# echo $PATH

No spaces.

What happens if you type “whereis gcc”? However, you would have to have installed Debian in a strange way not to have a valid C compiler.

I simply downloaded the iso and uploaded it to virtualbox. I downloaded the iso 11.0.

I was able to solve the problem by re-running the “sudo contrib / scripts / install_prereq install” command; in fact, by re-running it, the script performed many more operations than the first time I ran it. Don’t ask me because you will surely know more than I do.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.