Asterisk configuration?


im a student of computer science in germany and because we just got 2 months of holidays
and the wheather sucks i had the idea to install linux und mmh :astonished: work with it a bit.
after some days of suffering i read an article in a computer magazine about asterisk.
it was about saving some mobile costs.
it gives u a config that should work.
thats the config:

but i just cant get it right

thats the asterisk output

Asterisk Ready.
– creating pipe for PLCI=0x101 msn = asteriskmsn
> sent ALERT_REQ PLCI = 0x101
– started pbx on channel (callgroup=0)!
– Executing Wait(“CAPI[contr1/asteriskmsn]/0”, “1”) in new stack
– Executing AGI(“CAPI[contr1/asteriskmsn]/0”, “callback.agi”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/callback.agi
– AGI Script callback.agi completed, returning 0
– Executing Hangup(“CAPI[contr1/asteriskmsn]/0”, “”) in new stack
== Spawn extension (capiin, asteriskmsn, 3) exited non-zero on ‘CAPI[contr1/asteriskmsn]/0’
– CAPI Hangingup
> sent CONNECT_RESP for PLCI = 0x101
– removed pipe for PLCI = 0x101
– Attempting call on CAPI/asteriskmsn:themsnitssupposedtodial for s@capidialtone:1 (Retry 1)
Sep 15 17:38:14 NOTICE[10566]: chan_capi.c:1173 capi_request: didn’t find capi device with outgoing msn = asteriskmsn. you should check your config!
Sep 15 17:38:14 NOTICE[10566]: channel.c:1852 __ast_request_and_dial: Unable to request channel CAPI/asteriskmsn:themsnthatitshoulddial
Sep 15 17:38:14 NOTICE[10566]: pbx_spool.c:232 attempt_thread: Call failed to go through, reason 0

when i call the asterisk msn with my mobile its supposed to hangup immediatly and call another one of my msns

things i might have done wrong: using asterisk 1.0.6 i think and there is alot of stuff that allready is in the extension.conf and i dont know what of the stuff i need in it and what not.
i allready tried to delete everything in it and only let the stuff in it that was in the article but then it doesnt work completely.
and i tried to let everything in it except the demo and the output i have shown is the result of this

2.:astonished: maybe i put in the wrong msns but >< i dont know isdn card is contr0 and mmh in the asterisk output i read something about contr1 but no idea if that has anything to do with my suffering :stuck_out_tongue:

im a total newb XD please help

ah yeah im using SUSE 9.3, got an AVM fritcard pci and i use the chan_capi of

so nobody can help me ?