Asterisk as user on Slackware, no access to sound

I want to run asterisk as user, it start but no way to connect with sound card(so don’t load the alsa module).
I’ve added the user the the pulse and audio group


usermod -aG audio,pulse asterisk

ls -lhd /dev/snd/*

drwxr-xr-x 2 root root 80 Oct 26 2021 /dev/snd/by-path/
crw-rw---- 1 root audio 116, 10 Oct 26 17:56 /dev/snd/controlC0
crw-rw---- 1 root audio 116, 4 Oct 26 17:56 /dev/snd/controlC1


crw-rw---- 1 root audio 116, 9 Oct 26 17:56 /dev/snd/hwC0D0
crw-rw---- 1 root audio 116, 3 Oct 26 17:56 /dev/snd/hwC1D0
crw-rw---- 1 root audio 116, 6 Oct 26 17:56 /dev/snd/pcmC0D0c
crw-rw---- 1 root audio 116, 5 Oct 26 17:56 /dev/snd/pcmC0D0p
crw-rw---- 1 root audio 116, 7 Oct 26 17:56 /dev/snd/pcmC0D1p
crw-rw---- 1 root audio 116, 8 Oct 26 17:56 /dev/snd/pcmC0D2c
crw-rw---- 1 root audio 116, 2 Oct 26 17:56 /dev/snd/pcmC1D3p
crw-rw---- 1 root audio 116, 1 Oct 26 2021 /dev/snd/seq
crw-rw---- 1 root audio 116, 33 Oct 26 17:56 /dev/snd/timer



[Oct 26 18:15:11] ERROR[2636]: chan_alsa.c:188 alsa_card_init: snd_pcm_open failed: Connection refused
[Oct 26 18:15:11] ERROR[2636]: chan_alsa.c:284 soundcard_init: Problem opening alsa capture device
[Oct 26 18:15:11]   == No sound card detected -- console channel will be unavailable
[Oct 26 18:15:11]   == Turn off ALSA support by adding 'noload=chan_alsa.so' in /etc/asterisk/modules.conf

What i miss?
Of course asterisk were restarted

Solution found.

chmod +x /etc/rc.d/rc.pulseaudio 
/etc/rc.d/rc.pulseaudio start
/etc/rc.d/rc.asterisk restart
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.