Asterisk ARI Authentication

Hi all, I want to begin with ARI and set it up , but if I send a request for example ~/ari/channels , the response is as follows

{
“message”: “Authentication required”
}

and I don’t know how can I apply username and password.
The configuration file is as follows

ari.conf

[general]
enabled=yes
pretty=no
websocket_write_timeout=100
allowed_origins=*

[freepbxuser]
type=user
password=*******
password_format=crypt
read_only=no

How can I test this request with Postman. Can anyone help me to resolve the issue?
Thanks

I’ve never used postman, but you can use the api_key parameter to pass username and password. For example:

GET /ari/channels?api_key=username:password

Postman : in the collection, you have to activate the basic auth in authorization, then apply the authorization option ‘inherit from parent’ for each request you build in this collection

or for each request, you must populate the authorization with basic auth and your credentials

Thanks both @jcolp and @jcbru0560 for your answers. I tried both tips but in both it says an identical response error

{
“message”: “Authentication required”
}

How can I use asterisk logging, probably it can help me. I tried with “asterisk -rvvvvvvv”, but nothing was printed about ari requests.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.