Asterisk and Zingotel


#1

Ok I got this up and going but I can’t receive incoming calls. I can receive incoming calls if I use xten’s softphone so I know that zingo’s setup is correct.

Right now with this config it goes straight to my voicemail on zingotel.

[general]
context=default ; Default context for incoming calls
bindaddr=0.0.0.0 ; IP address to bind to (0.0.0.0 binds to all)
srvlookup=yes
defaultexpirey=600

; Register your zingotel line:
register => myaccountnumber:mypass@sip1.whistlertel.com/myaccountnumber

;Outgoing calls through zingotel:
[zingotel-out]
type=peer
host=sip1.whistlertel.com
username=myaccountnumber
secret=mysecret
fromuser=myaccountnumber
fromdomain=sip1.whistlertel.com
defaultexpirey=600
disallow=all
allow=ulaw
canreinvite=no

; Incoming calls from zingotel:
[zingotel-in]
type=user
host=sip1.whistlertel.com
context=zingotel-in
relaxdtmf=yes

; Local extension:
[myaccountnumber]
type=friend
secret=mypw
nat=no
host=dynamic
;insecure=very
mailbox=myaccountnumber@default
context=zingotel-out

my extension.conf looks like this…

exten => _X.,1,Dial(SIP/${EXTEN:1})
exten -> _x.,2,SetMusicOnHold(default)
exten => _X.,3,Playback(invalid)
exten => _X.,4,Hangup

[zingotel-out]
exten => 68,1,VoicemailMain(${CALLERIDNUM})
exten => 68,2,Hangup
exten => _X.,1,Dial(SIP/${EXTEN}@zingotel-out)
exten -> _x.,2,SetMusicOnHold(default)
exten => _X.,3,Playback(invalid)
exten => _X.,4,Hangup

Its a very basic setup just to get it up and running. I can make phone calls just fine…

Whe I do a sip debug I don’t even see anything happen when I call my voip number so I don’t think its even getting to my pbx

PLEASE HELP :smile:

Justin


#2

I’m having the same problem. Did you fix it?

David


#3

I got it to work…

A@H >Trunk

Outgoing Settings

Trunk Name ZingoTel
PEER Details

authname=<your phone #>
canreinvite=yes
context=from-pstn
dtmf=inband
dtmfmode=inband
fromdomain=sip1.whistlertel.com
fromuser=<your phone #>
host=sip1.whistlertel.com
insecure=very
regexten=<your phone #>
secret=PASSWORD
type=peer
user=phone
username=<your phone #>

Register <yourphone #>:PASSWORD@sip1.whistlertel.com/<yourphone #>

Add in your sip.conf in the
[general]
defaultexpirey=600

In A@H Inbound add a DID route for your phone number…

David