Asterisk and SPA2102 System : Problem receiving calls from c

Hello,

I am having problems receiving calls on my voip line from cell phones.

Asterisk tries to “DIAL” my ata, but I get this error:

[Mar 1 20:20:45] WARNING[7959] app_dial.c: Unable to create channel of type ‘SIP’ (cause 20 - Unknown)

or “Cause 406 - Not Acceptable”

---- after this “dial” failure, the cell phone is sent to my asterisk voicemail, which works fine.

I dont know why, but a friend of mine who used telus went from being unable to call me (cause 406 not acceptable) to being able to call me when he called telus to have his callerid made public. Might just be a coincidence.

Any idea? This is in Canada, and my asterisk 1.4.22 setup is running on an “unslung” NSLU2.

Thanks

What codec do you use?

my sip.conf file has the following codec-related lines:

disallow=all
allow=ulaw

Is that what you needed?
Thanks for helping.

Ok, try with allow=all and comment disallow line, this is to discard a codec problem, sometimes the 406 error is caused by a codec issue.

ok, will try.

Which codecs should I put in my modules.conf ?
Again, this is an NSLU2 setup so I had slimmed this install as much as possible. I might be missinga codec here as well…

Most used codecs are ulaw, alaw and g729.

Thanks.

I’ll add alaw and hope I dont need g729:

From: voip-info.org/wiki/view/Aste … ksys+NSLU2

[quote]Limitations

Currently the codecs g723, iLBC and g729 are not supported (would require floating point processor/emulation or would have to be replaced by an integer implementation of the codec).
The performance is sufficient for home/SOHO use - eg. a few lines using SIP and IAX. The slug’s IXP400 should have enough horse power for a home PBX with up to 4 lines, when less CPU intensive codecs (like GSM and 711u) are used. [/quote]

Still doesnt work. Here’s what I see in asterisk, followed by (part) of the extensions.conf that lead to this.
extension “2003” is my ATA.
the other extension is a normal phone I want to ring when I’m being called on my voip line.


And the ata how is configured and check if its reistered with asterisk.

Hi Navaismo,

The ata is set up to register on my Asterisk LAN IP, using login/password for extension “2003”.

All non-cell phones call get through and work fine.

Here’s what I have on the Spa2102.
Preferred codec: g711u , use pref codec only: no

Try forcing the codec g711u in your ata, if you increase the debug in your asterisk can you see which codec its using your call.

This issue happens with all incomings calls?

No, only with cells originating from cell phones.

All the other incoming calls work fine.
I’ll try forcing the codec.thanks

Hi navaismo,

Thanks for your help so far, very appreciated.

Quick newbie question though: How do I increase debug? I tried increasing verbosity by starting asterisk by typing

but it doesnt work.

Thanks

edit: I type “set core debug 10000” in the CLI and I still dont see which codec is being used.

And with “core set verbose 10”.

I already set verbose to 30, still no codec appears…

So try debug the SIP channel wit “sip set debug on”

thanks.

Here a screenshot of what I get when calling from a normal phone (so no error 406)
Many codecs are named… how do I know which one is used?

thanks

And the output from cellphone call. How looks?

I’m afraid that will have to wait until this evening, I dont have one handy :smile:

Which part tells me the codec though?
Thanks