Asterisk 13 VM's and replication


I am having an issue with the most recent stable version of Asterisk. I am running Asterisk 13.8.2 on a CentOS 6.8 32bit VM. The issue arises when replicating VM’s. I have always used Veeam replication between hosts (VMware ESXi standalone servers) in the past using older Asterisk versions (Asterisk 1.8) with no problems. But with the most recent stable version, the replication process seems to break Asterisk, preventing it from starting correctly. I am having the exact same issue when running Asterisk on a 64bit CentOS 6.8 VM. I have tried using different Veeam Replication versions, and replicating to different hosts. The issue stays, regardless.

When I run “service asterisk status” on the replicated VM’s, I always get the “asterisk dead but subsys locked” message. I tried everything to get Asterisk to start, but nothing seems to work. Any insight on how to resolve this issue would be greatly appreciated.

No one ever had an issue with replicated FreePBX VM’s and the asterisk service not starting up?

UP !

Anyone ever had this problem before?

You may have better luck asking the FreePBX Community or on a VMWare forum.

I thought since the problem was with the Asterisk service not starting up I would have luck on here

I had too many problems with 13.8, so I ended up moving to 13.12. Not sure if you’re having the same problems I did, but run “core show taskprocessors”. Things, for me, were queueing up and never clearing. It had to do with chan_sip and realtime voicemail. It would lock up and use all available memory. Haven’t had a single problem since I upgraded.