Asterisk 13 is not starting

[root@localhost ~]# asterisk -vvvvvgc
FATAL: ThreadSanitizer can not mmap the shadow memory (something is mapped at 0x55a96afe6000 < 0x7cf000000000)
FATAL: Make sure to compile with -fPIE and to link with -pie.

[root@localhost ~]# gcc --version
gcc (GCC) 7.3.0
Copyright (C) 2017 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO

I have tried with version 18, Centos version 7.9, 7.7 but no luck at all. Could anyone help on this please.

Asterisk 13 is no longer supported.

Thank you David, Same issue I’m facing at Asterisk 18 and it’s LTS.

It seams some issue with share memory when we are running asterisk. I have GCC 7.3 but no luck at all. Any help will be appreciated.

Literally the message is saying that it is trying to place something in a particular memory range, but there is already something there. -fPIE causes shared libraries executables slightly bigger, but such that they don’t have to be loaded at a fixed address.

ThreadSanitizer is an optional debugging tool and has extended support status, which means it is only supported by the open source community, not by Sangoma’s Asterisk team.

I’d simply suggest disabling it, although this might also help: Asterisks wont start | The VoIP-info Forum

This like is not accessible .

I was followed the same installation steps as per link

But in AWS and Azure it’s working fine but CTRLS VM always had an issue.

I think you should take this up with the author of the article. I notice that the article assumes quite a few things that are local policy choices and nothing to do with the platform or the version.

It looks like including a link to it has been misinterpreted as some sort of DDOS on the site. You could try the wayback machine.

continue on it…
I did some googling and found that Asterisk need module to install and this module is for memory related stuff like ThreadSanitizer and ThreadAddress .
As i remove it then asterisk didn’t install and if I tried to run asterisk then Error is change. which means it’s somthing code level + Operating System dependent in Asterisk project.
I am not expert in C or C++ but it’s on the basis of googling…
Below is reference link for further details.

ThreadSanitizerCppManual · google/sanitizers Wiki · GitHub (FAQ section)

/bin/ld: cannot find /usr/lib64/
collect2: error: ld returned 1 exit status
make[1]: *** [asterisk] Error 1
make: *** [main] Error 2
[root@localhost asterisk-13.33.0_kit]# asterisk
asterisk: error while loading shared libraries: cannot open shared object file: No such file or directory
[root@localhost asterisk-13.33.0_kit]#

Have you disabled it in make menuconfig? Did you remove it using the OS package manager, and did you re-run configure after removing it. It is configure that checks what libraries are present, and the library checking may be, in part, based on indexes of libraries, rather than the libraries themselves.

I found the github section; that is how I knew it was a debugging tool.

1 Like

The forum post is this one in their search index:

and speculates on a GVSIP script being limited to OS version 6.

I can’t quote the exact and full contents, for copyright reasons.

A big thanks to you David.
Issue is resolved after removing package from make menuselect. and now asterisk start working.

I hope it will not impact any further work of Asterisk itself.

Actually, I think cloudfare may have taken a disliking to your IP address, which seems to be an Indian mobile network… cloudfare is the company that seems to run most people’s web servers, these days, and I think they do have a significant false positive rate. One of the reasons I think they are used is that they are in a better position to survive a DDoS attack that individual small to medium sized sites.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.