Asterisk 13.1-cert2 crahsing with SEGFAULT on outgoing calls

Hi everyone!

First of all. We’re trying somenting that’s not fully supported, so if you don’t bother to deal with such environments, please do not waste time on my posting here :wink:
The reason for this post is to figure out, how we should proceed, so I would delighted I you could provide me with a few hints about how to progress with our issue here.

We are evaluating an Installation with a Digium TE820 Card being handed off to a virtual machine by VMware6. (Yes, it is the customer’s idea) The idea why theyr’re doing this is to get more hardware-independence and availability. The host is running just one VM (The Asterisk I am talking about) and the PCIX Card is exclusively passed to that VM.
I am not sure whether the problem we have is related to virtualization and therefore I’d like to know your highly estimated opinions. (My questions are at the end of this post – maybe I am just not seeing some obvious incompatibility)

Our Problem is that on outgoing calls Asterisk crashes with a SEGFAULT either during the call or immediately afterwards. Incoming calls work flawlessly. During normal operations the calls would be submitted by IAX (form a backend Asterisk), but during testing we have also tried directly registered SIP phones… I do not want to withhold the dmesg glory :wink::

[16760.709494] asterisk[2368]: segfault at 144 ip 00000000005199ec sp 00007f20899f1360 error 4 in asterisk[400000+29a000]

A few words about the environment:
Guest (=Asterisk):
Debian Linux 3.19.8-amd64+ with a self-compiled 1000Hz kernel, original VMware Tools installed



We’re using chan_sip, but have also compiled pjsip for future developmens


Wildcard TE820 (5th Gen)


My questions would be
• Do you think this venture is BS alltogether? I could go on for few opages about the customer’s reasoning, buit I guess their Basic iodea is well thought-through, so they want to konow if our Installation could be run in such a Setup. (The both frontend Asterisk-machines are handling approx 10.000 calls a day each)
• From all the versions above, could it be that I have without seeing it chosen some versions that are old or inherently incompatible?
• I have searched for some kind cumulative patches that could be available, as I have found some bug reports that describe similar issues. Unfortunately I haven’t found a suitable patch. The file certified-asterisk-13.1-cert2-patch.gz in the download directory just seems to update an existing cert-13.1 to 13.2.
Are there any ‘cumulative patches’ If yes, where can I find them?
• If I submitted the whole issue as a bug, would I p**s off the guys maintaining the code as my environment uses a virtualized card?
• I haven’t yet signed up to Asterisk Issue tracker. Is there a detailed description of which files (Coredump, strace-output) will have to be provided for submitting the bug and how to create them? As I am mainly a networking guy using Linux, my knowledge on debugging issues is on the weak side :wink:

Thanks in advance for your time
Greetings from Austria,

Information on getting the information to debug a crash can be found at … +Backtrace

I don’t understand why you would expect there to be cumulative patches from every version to every other, or even from every version to the latest. If you really want to jump a long way, it is easier to download the complete source.

Whilst it shouldn’t cause crashes, running hardware with 20ms latency requirements on a virtual machine doesn’t seem to be a good idea. Also running a 1kHz kernel on such a machine seems an overkill, as, without a lot of optimisation of the hosting environment, and probably even with it, timing jitter is likely to be a lot more than 1ms.

The main problem in getting a bug progressed, assuming you can reproduce it on the latest version, would be that no-one is likely to have a suitable test environment, so, unless the cause is obvious from the core dump and a quick analysis of the code, it may be difficult to reproduce.

Hi thanks for your reply!

As I said before, it’s a customer idea - your posting has helped me a lot in the sense that I have now some additional arguments from a third party (‘moves like spencer’ :wink: about the virtualization of such a system in general…

Regarding the pathces I have misunderstood the basic idea of how the Patches are handled- sorry. I thought there are cumulative patches that fix some things within a given Version that are publsihed on a regular basis. I did not intend to compile me up from some old version, just tried to stay within the certified version. :wink:

I will now try out the latest Version of Asterisk and check whether the problem persists!

Best regards,

Hi everyone!

FYI (in case some else is tasked of to do such a thing)
I updated to 13.6.0, everything runs like a charm. We processed 2700 calls on this system in one day - no customer complaints… So everything seems to be running smoothly