Asterisk 12 pjsip net2phone registration

I’m migrating to Asterisk 12 with pjsip. Before I was using sip which worked with net2phone.
Now for registration it would appear that net2phone requires that we append /siptrunking to the end of the server uri which the pjsip parser rejects as an invalid uri.

It would also appear that pjsip is reading the pjsip.conf for registration and not the odbc table ps_registrations. Whereas for everything else it seems to be reading the database. What’s going on?

The net2phone uri appears to be

without the /siptrunking I’m getting a 407 reject

Best regards,
Pete Kirkham

As usual I’m answering my own question.
Now it works. Having set up the following entries in the database:
note in particular in server_uri
ps_aor, ps_auth, ps_endpoint

Not really sure why the same information appears in different places but now the registration works.

Also note in dialplan
where before with chan_sip the number you’re dialling was at the end now it’s in front of the endpoint you defined above

exten = _00ZXXXXXXXXXX,2,Dial(PJSIP/${EXTEN:3}@net2phone)

Have fun,