Asterisk 11 http and manager

Hi,

After upgrading my asterisk 1.8 to 11 my “build-in http server” is not working anymore.
I already tried to install it again, checked my firewall and config files.

[code]libby:/usr/src/asterisk-gui# make checkconfig
— Checking Asterisk configuration to see if it will support the GUI —

  • Checking for http.conf: OK
  • Checking for manager.conf: OK
  • Checking if HTTP is enabled: OK
  • Checking if HTTP static support is enabled: OK
  • Checking if manager is enabled: OK
  • Checking if manager over HTTP is enabled: OK
    — Everything looks good —
  • GUI should be available at http://libby:8088/asterisk/static/config/index.html
    [/code]

========================================================================= Connected to Asterisk 11.0.1 currently running on libby (pid = 8771) libby*CLI> http show status HTTP Server Status: Prefix: Server Disabled

even when I try telnet localhost 8088 it give “connection refused”??

problem solved.
It seems that after upgarding from 1.8 to 11 you also must use http.conf and manager.conf from the configs dir. Asterisk 11 is not working with my old files from 1.8 for some reason

by the way, how did you upgrade asterisk 1.8 to 11?

I was dealing with asterisk 11 but getting compile error all the time:

res_http_post.c:40:25: fatal error: gmime/gmime.h: No such file or directory
compilation terminated.
make[2]: *** [res_http_post.o] Error 1
make[1]: *** [res] Error 2
make[1]: Leaving directory `/usr/src/asterisk-11.1.0-rc1’
make: *** [_cleantest_all] Error 2

So I have changed my mind and try apt-get install asterisk, which is asterisk 1.8.10.1 because it is installed succesfully and works with asterisk gui easily. However, I am not able to upgrade to asterisk 11.

I will be so much happy if you help me. Thanks in advance

Have you tried a released version? rc-1 means it is a release candidate, which will be replaced by an rc-2, etc., if bugs are found, or with a version without the suffix, if considered releasable.

If you have started from ./configure and you get these compile errors, it means that there is something missing from the autoconfig configuration or in the information that tells menuconfig the required dependencies. This should be reported on the issue tracker; it could potentially force an rc2, so needs to be reported quickly.

The latest released version is 11.0.1.

[quote=“osmanaslan”]by the way, how did you upgrade asterisk 1.8 to 11?

I was dealing with asterisk 11 but getting compile error all the time:

res_http_post.c:40:25: fatal error: gmime/gmime.h: No such file or directory
compilation terminated.
make[2]: *** [res_http_post.o] Error 1
make[1]: *** [res] Error 2
make[1]: Leaving directory `/usr/src/asterisk-11.1.0-rc1’
make: *** [_cleantest_all] Error 2

So I have changed my mind and try apt-get install asterisk, which is asterisk 1.8.10.1 because it is installed succesfully and works with asterisk gui easily. However, I am not able to upgrade to asterisk 11.

I will be so much happy if you help me. Thanks in advance[/quote]

I downloaded Asterisk 11.0.1 then:
./configure
make menuselect
make && make install

Thank you very much for your kind responses. Finally, I was able to solve the problem. I was using a language setting other than english. So, unexpectedly I realized that some letter may differ in various languages which means that compiling error is caused by letter cases. Completely I have changed regional settings into (US)english forcedly :smile:

If you dont know this situation, you can advise this solution other guys. Thank you very much…