Asterisk 11.7 - Spandsp breaks webrtc & motif

Hi All

I’m not sure whether this should be a bug report, but in bringing up a new Ubuntu 12.04.4 server and Asterisk 11.7.0 to play with Webrtc, I was able to make it work just fine. sipML5-driven calls working, audio in both directions, and also a couple of Google Voice accounts for both incoming and outgoing calls. Installing uuid-dev via apt-get worked a treat.

THEN I decided to try spandsp-0.0.6 - which I got to build & install just fine, then rebuilt asterisk. “fax show capabilities” worked etc.At this point however WebRTC lost bi-directional audio, and Google Voice (Motif) calls failed with the dreaded “Unable to add Google ICE candidates as ICE support not available or no candidates available” message.

The point is that I wasn’t actually making or receiving fax calls at the time. Removing the spandsp libraries & headers (via make uninstall) and rebuilding asterisk from source re-enabled working WebRTC and Google Voice, with zero .conf file changes.

Is it possible that compiling with the SpanDSP libraries somehow breaks ICE support in 11.7? Has anyone else tried or otherwise experienced this?