Asterisk 1.8 with Voxalot - strange password problem


#1

I have an Asterisk 1.8 server, and I want to call inbound and outbound via Voxalot. I have this in sip.conf:

[voxalot]
type=peer
fromuser=voxalotnumber
defaultuser=voxalotnumber
remotesecret=mypassword
secret=mypassword
host=eu.voxalot.com
fromdomain=voxalot.com
callbackextension=allphones; register to host and specify extension for incoming calls

A summary of my problem: the strange thing is that outbound calling through Voxalot needs my password in ‘secret’. But I can only be called when I have ‘remotesecret’ defined and secret removed. Registering is no problem though, with remotesecret or with secret.

So i’m trying to figure out why this happens. Is it correct that ‘secret’ is mainly for ‘friends’ who authenticate and register against Asterisk, like your local phones? Then ‘remotesecret’ is just for registering to other VSPs and calling out? If so in this case something is wrong: if I want to call, this would need the ‘remotesecret’ right? But it actually needs the ‘secret’, otherwise it won’t work:
[ul][size=85][Dec 11 21:37:17] NOTICE[15781]: chan_sip.c:19013 handle_response_invite: Failed to authenticate on INVITE to ‘“IPphone” <sip:@voxalot.com>;tag=bs5f453edb’[/size][/ul]

And then there’s thus this weird behaviour that I cannot be called when ‘secret’ is used.

Does anyone have an up to date example how to use Asterisk with Voxalot? These secrets in particular…
Thanks

My Asterisk version is:
Asterisk 1.8.0 built by slug @ oldbuilder on a i686 running Linux on 2010-11-30 05:46:07 UTC


#2

There’s a sip peer definition from the Voxalot FAQ here:
faq.voxalot.com/action/view/Asterisk

Any joy with that?


#3

Thanks, that page confirms that I have the correct settings for Voxalot. Except for the secrets of course: apparently that page was created before the remotesecret setting was introduced into Asterisk. Since Asterisk works perfectly for inbound and outbound, depending on which of the secret settings are enabled, this can only be a bug in Asterisk when using Voxalot. I challenge anyone to try this with Voxalot themselves.


#4

At long last, this was indeed some sort of bug apparently: reviewboard.asterisk.org/r/1107/
Strange that no-one here could reproduce this! For months I had to make two entries, one for calling out and another for registering.

So if this patch is implemented it should work with one entry again, I think… I will test and update here.


#5

It looks like it was implemented in 1.8 and 10?