Asterisk 1.6 - builtin_atxfer: Did not read data


on special circumstances I get the error builtin_atxfer: Did not read data.
When I receive a call from outside over DAHDI (Astribank) and I want to atxfer the call everything ist OK.
I get the “transfer” voice and the phone rings on the other side. While the phone is ringing I hang up making it a blind transfer.
When nobody answeres the ringing phone the call automatically goes to a group. The call then returns to me, because I am in this group.

After I pick up the phone I am not able to do a second atxfer. I can press the atxfer code (## is configured in features.conf) and hear the “transfer” voice, but right after dialing the next digit I get builtin_atxfer: Did not read data.

Does anybody have an idea why this is happening? Maybe a bug? I tried this with all 1.6 versions. Right now I use RC4.


Hi all,
i’m having the same problem.
had you solved it?

the specific error is: features.c:1439 builtin_atxfer: Did not read data.
i’m using an audiocodes MP-114 but i enconter the same error with a grandstram 4008
my “atxfer digits” are *1
codec is g729
asterisk: Asterisk built by buildd @ roseapple on a i686 running Linux

from a sip phone -> asteisk -> sip/fxs gateway -> analog phone.
when i try to transfer the call from the analog phone to any other phone i push *1, moh starts correctly but after composing the extension i wish to tranfer the call i get the following messages:

    -- Started music on hold, class 'default', on SIP/12-0000136d
    -- <SIP/11-0000136e> Playing 'pbx-transfer.gsm' (language 'en')
WARNING[28287]: features.c:1439 builtin_atxfer: Did not read data.
    -- Stopped music on hold on SIP/12-0000136d
    -- <SIP/11-0000136e> Playing 'beeperr.gsm' (language 'en')


Hi all,
it seems that this behavior is caused by the M() option in dial
if i use

i have no problem

otherwise adding the M() command

i experience what described in my previous post.

as a workaround can anyone suggest me a way to log “when the call is answered and who answes” ?
(who is not obvious with a DIAL_STRING like “SIP/01&SIP/02&SIP/03”)

any idea?

Why are CDRs inadequate?

becouse i wish to track down tramsfers etc…
or simply if i want to trigger special actions on answers.

btw upgrading to asterisk fixes this issue.