Asterisk 1.4+Mera MVTS II 3.1.2

Hi,

Im trying to interconnect Asterisk and Mera system but everytime i try to send call from asterisk or mera i get cause code 18 on both sides im sure they can see each other but they don’t reply to sip invites at all. Im using IP authentication on both sides.

Here’s the sip.conf

[mera]
type=peer
host=y.y.y.y
disallow=all
allow=g729
allow=ulaw
allow=alaw
context=mera
qualify=yes
canreinvite=no
call-limit=8

extensions.conf:

exten => _NXXNXXXXXX,1,NoOp()
exten => _NXXNXXXXXX,n,Dial(DAHDI/r0/${EXTEN})
exten => _NXXNXXXXXX,n,Hangup()

exten => _91NXXNXXXXXX,1,NoOp()
exten => _91NXXNXXXXXX,n,Dial(SIP/mera/${EXTEN})
exten => _91NXXNXXXXXX,n,Hangup()

asterisk CLI:

– Executing NoOp(“SIP/1065-b7a21f70”, “”) in new stack
– Executing Dial(“SIP/1065-b7a21f70”, “SIP/mera/111632645XXXX”) in new stack
We’re at x.x.x.x port 18618
Adding codec 0x4 (ulaw) to SDP
Adding codec 0x100 (g729) to SDP
Adding codec 0x8 (alaw) to SDP
Adding non-codec 0x1 (telephone-event) to SDP
13 headers, 13 lines
Reliably Transmitting (NAT) to y.y.y.y:5060:
INVITE sip:111632645XXXX@y.y.y.y SIP/2.0
Via: SIP/2.0/UDP x.x.x.x:5060;branch=z9hG4bK1f632dd0;rport
From: “1065” sip:1065@x.x.x.x;tag=as7c1e70a2
To: sip:111632645XXXX@y.y.y.y
Contact: sip:1065@x.x.x.x
Call-ID: 27f896e10269a64e5666995a0736de5b@x.x.x.x
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Max-Forwards: 70
Date: Mon, 07 Sep 2009 19:39:56 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Content-Type: application/sdp
Content-Length: 287

v=0
o=root 2497 2497 IN IP4 x.x.x.x
s=session
c=IN IP4 x.x.x.x
t=0 0
m=audio 18618 RTP/AVP 0 18 8 101
a=rtpmap:0 PCMU/8000
a=rtpmap:18 G729/8000
a=fmtp:18 annexb=no
a=rtpmap:8 PCMA/8000
a=rtpmap:101 telephone-event/8000
a=fmtp:101 0-16
a=silenceSupp:off - - - -


-- Called mera/111632645XXXX

ViciDBAst229*CLI>
<-- SIP read from y.y.y.y:5060:
SIP/2.0 100 Trying
Via:SIP/2.0/UDP x.x.x.x:5060;branch=z9hG4bK1f632dd0;rport
From:"1065"sip:1065@x.x.x.x:5060;tag=as7c1e70a2
To:sip:111632645XXXX@y.y.y.y;tag=ffff1400ff62ff10ff000014ff16ffff
Call-ID:27f896e10269a64e5666995a0736de5b@x.x.x.x
CSeq:102 INVITE
Contact:sip:111632645XXXX@y.y.y.y;User=phone
Server:MERA MSIP v.1.0.2
Content-Length:0

— (9 headers 0 lines) —
== Refreshing DNS lookups.
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Manager ‘sendcron’ logged on from 127.0.0.1
== Parsing ‘/etc/asterisk/manager.conf’: Found
== Manager ‘sendcron’ logged on from 127.0.0.1
== Manager ‘sendcron’ logged off from 127.0.0.1
== Manager ‘sendcron’ logged off from 127.0.0.1
ViciDBAst229*CLI>
<-- SIP read from y.y.y.y:5060:
SIP/2.0 480 Temporarily Unavailable: No response
Via:SIP/2.0/UDP x.x.x.x:5060;branch=z9hG4bK1f632dd0;rport
From:"1065"sip:1065@x.x.x.x:5060;tag=as7c1e70a2
To:sip:111632645XXXX@y.y.y.y;tag=ffff1400ff62ff10ff000014ff16ffff
Call-ID:27f896e10269a64e5666995a0736de5b@x.x.x.x
CSeq:102 INVITE
Server:MERA MSIP v.1.0.2
Reason: Q.850;cause=18;text="No user responding"
Content-Length:0

— (9 headers 0 lines) —
– Got SIP response 480 “Temporarily Unavailable: No response” back from y.y.y.y
Transmitting (NAT) to y.y.y.y:5060:
ACK sip:111632645XXXX@y.y.y.y SIP/2.0
Via: SIP/2.0/UDP x.x.x.x:5060;branch=z9hG4bK1f632dd0;rport
From: “1065” sip:1065@x.x.x.x;tag=as7c1e70a2
To: sip:111632645XXXX@y.y.y.y;tag=ffff1400ff62ff10ff000014ff16ffff
Contact: sip:1065@x.x.x.x
Call-ID: 27f896e10269a64e5666995a0736de5b@x.x.x.x
CSeq: 102 ACK
User-Agent: Asterisk PBX
Max-Forwards: 70
Content-Length: 0


-- SIP/mera-094f10e8 is circuit-busy

== Everyone is busy/congested at this time (1:0/1/0)
– Executing Hangup(“SIP/1065-b7a21f70”, “”) in new stack
== Spawn extension (mera, 111632645XXXX, 3) exited non-zero on ‘SIP/1065-b7a21f70’
Destroying call '27f896e10269a64e5666995a0736de5b@x.x.x.x

TIA

One my friend had furious problems with Mera MSIP.
I think he solved them setting user agent (in sip.conf) different from Asterisk.

[quote=“bira_more”]One my friend had furious problems with Mera MSIP.
I think he solved them setting user agent (in sip.conf) different from Asterisk.[/quote]

Hi i tried to change ng user agent same with mera, but still doesn’t work. Do you know what your friend set in the user agent string?

[quote=“bira_more”]One my friend had furious problems with Mera MSIP.
I think he solved them setting user agent (in sip.conf) different from Asterisk.[/quote]

Hi i tried to change the user agent same with mera, but still doesn’t work. Do you know what your friend set in the user agent string?

My friend sugests:
canreinvite - but not sure if yes or no - try first one, then second
insecure=port,invite