Asterisk-1.2.14-netsec and libmidcom-0.2 Problem

I hv a Centos 4.4 system loaded with software development package and the following files were downloaded asterisk-1.2.14-netsec.tar.gz and libmidcom-0.2.tar.gz

  1. On the asterisk-1.2.14-netsec, I run the following steps to build the asterisk-1.2.14 binary (as root).

make install

No errors reported. The execution of asterisk (/usr/sbin/asterisk) and asterisk CLI (asterisk -rvvvvvvvvvvvvvvvvvc). Then I kill asterisk process (killall asterisk) and ps uax | grep asterisk confirmed no asterisk process running.

  1. On the libmidcom-0.2, I run the following steps to build the libmidcom’s library and header files.

make install

No errors, library files were copied to (/usr/lib/asterisk) and headers files were copied to (/usr/include/asterisk)

  1. Reinstall asterisk-1.2.14-netsec with the following steps

make clean
make install

Errors reported on “make install”, the follows message appears

*** No rule to make target ‘/usr/include/asterisk/res_netsec.h’ needed
by ‘chan_sip.o’. STOP

make: xxx [subdir] Error 1

I check the above directory (/usr/include/asterisk/res_netsec.h’) that header file was missing. But I verify it was there after the ‘make install’ for libmidcom, which copy that header file to /usr/include/asterisk/. Apparently, ‘make install’ for asterisk-1.2.4-netsec (reinstall steps) remove that header file.

Do I need to patch ‘Makefile’ for reinstall asterisk-1.2.14-netsec or I missed out some steps to get asterisk-1.2.14-netsec to accept libmidcom.0.2