AsterFax Help!

Hi There -

I am still needing help with AsterFax! UGH! I am running TrixBox 1.2.2 and from what I can tell, AsterFax is installed by default.

I am able to send myself a fax (into Asterfax) and it comes through perfectly! My only problem is sending faxes out via Outlook.

I have done a lot of research on the internet and from what I can tell, the easiest way to configure the outbound fax is to create a second account in Outlook to connect ‘direct’ to the AsterFax SMTP server. I have done this and tried numerous settings but can’t seem to get outbound faxing to work.

When setting up the second account in Outlook, what do you use as my SMTP server settings??? I am using Outlook 2003 and everything I have tried does not work. I’ve tried using fax.local, localhost, localhost.localdomain, the IP address of my Trixbox server and nothing seems to connect to the SMTP server. How can I find my SMTP server name in TrixBox??

I’ve also tried sending outbound faxes using 3035551212@fax.local and the e-mail is alway returned “undeliverable”.

Any help will be greatly appreciated.


From DOS on your PC…

type "telnet 25

You should get something simular to…

Connected to (
Escape character is ‘^]’.
220 Welcome to AsterFax version 1.0free.

If you get a connection refused, then it will not matter what you put in Outlook, because you have a bigger issue.

Post back what you get.

BTW - To kill he connection, type “quit” the

I get a “connection failed” message. I have opened up port 25 tcp on my dsl router and still no connection.

I can run putty and telnet to the Trixbox machine but it looks like it is on port 22.


Use putty to connect ot the box via ssh, and then run “telnet localhost 25”. Post back what you get.

Below is a screen shot of what the response was from the PUTTY/Telnet:
login as: root
root@’s password:
Last login: Tue Oct 24 13:30:39 2006 from

Welcome to trixbox

[root@asterisk1 ~]# telnet localhost 25
Connected to localhost (
Escape character is ‘^]’.
220 asterisk1.local ESMTP Sendmail 8.13.1/8.13.1; Tue, 24 Oct 2006 18:54:59 -060 0

That tells you that port 25 (SMTP) is open and running for local connections–it does not confirm that the smtp->fax gateway is functioning–we’ll have to test that later. Anyhow, there is something that is blocking your PC from connecting to the box, so describe the network configuration that you have…

I have a very simple home network setup. I have an Actiontec DSL Modem that brings in my DSL from Qwest. I have the ethernet cable running directly from my DSL modem to a network switch (Linksys) to the WAN port. I then connect the Trixbox machine into a port on the network switch along with my desktop PC (seperate computer).

The IP address to my DSL modem is, then my PC uses I have a Sipura 2100 connected to the network switch as well and it uses and finally the Trixbox uses

I have tried opening port 25 on my DSL modem to see if that would allow the telnet connection to the Trixbox but it does not.

Also, I have my Trixbox IP sitting in the DMZ zone on my DSL Modem.