[ARI] externalMedia no packets unless DTMF is sent first on channel

Have there been any changes to how externalMedia works between asterisk 17 and 18?

We have some scripts that receieve/forward rtp packets. These scripts have been running without issue for months on v17. Now we just tried running them now on Asterisk v18 and the don’t work as expected. We diff’ed all the config files between servers and they are almost identical.

Our issue is that our script receives no packets unless DTMF are sent on the channel. I’ve tried playing audio on the channel, waiting different amount of times, etc but only DTMFs seem to do the trick.

I thought strictrtp could have an effect on this but I have it enabled in all servers.

Not that I can think of, and haven’t seen any other reports of such. You’d want to verify everything. That Asterisk is sending or receiving RTP normally, check debug logs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.