[app_queue.so] can't load

Hi there,

I’m studying asterisk following , so far so good until reach “Automatic Call Distribution (ACD) Queues” section.

Firstly I found out there is no queue command under Asterisk CLI. Then I found the app_queue.so module loaded abnormal.

Here is some command I’ve tried:

localhost*CLI> module show like queue
Module Description Use Count
app_queue.so True Call Queueing 0
1 modules loaded

localhost*CLI> module unload app_queue.so
Unable to unload resource app_queue.so
Command ‘module unload app_queue.so’ failed.

localhostCLI> module reload app_queue.so
localhost
CLI>

localhost*CLI> module load app_queue.so
Unable to load module app_queue.so
Command ‘module load app_queue.so’ failed.

localhost*CLI> core show version
Asterisk 1.8.31.1 built by asteriskpbx @ localhost.localdomain on a i686 running Linux on 2014-10-21 04:39:58 UTC

As you can see the app_queue.so looks loaded, but all commands bounce back error except reload which gives nothing.

I tried noload => app_queue.so in the module.conf and load manually under CLI, doesn’t help. I’ve tried restart asterisk service and whole machine as well.

I randomly unload/load/reload some other app_*.so module all good.

I setup asterisk on two different physical machines, both have exactly same problem.

Could anybody help?

Thanks in advance!

Cheers,

YunYun

Did it throw any other errors when trying to load?
Do you have a queues.conf file in /etc/asterisk?

Hi Malcolmd,

The above are all errors prompt up, there nothing else. ( I logged in by -rvvv )

I don’t have queues.conf in /etc/asterisk.

Problem solved after I copy queues.conf.example to /etc/asterisk/queues.conf

I just follow the book,but by some how I missed the chapter before ‘queue member control through CLI’ which introduce how to create queue by queues.conf.

Thank you very much for your help!

Cheers,

Yay :smiley: