Anyone use PJSIP and Audiocodes FXS port used for paging

We have an Audiocodes Mediant 1000 with a FXS module. We have an overhead paging system connected to one of the FXS ports and were using chan_sip without any issues paging. Moved to chan_pjsip and can’t seem to find the write configuration within pjsip.conf to send the call from Asterisk to the Audiocodes.

Looking for any help or anyone with knowledge getting this to work with the audiocodes and pjsip?

My configuration when using chan_sip from sip.conf is below:

[mediant]
type=friend
dtmfmode=rfc2833
qualify=yes
nat=no
directmedia=no
t38pt_udptl = yes
disallow=all
allow=alaw
allow=ulaw
host=
context=incomingcontext

Have you tried using sip_to_pjsip in contrib/scripts to see if it can convert your config over?

You could also look at using the pjzip_wizard to make things easy on configuring.

https://wiki.asterisk.org/wiki/display/AST/PJSIP+Configuration+Wizard

PJSIP is very flexible and easy to use: On this link you will find all the necesary information to move to PJSIP
https://wiki.asterisk.org/wiki/display/AST/Configuring+res_pjsip

I initially used the sip_to_pjsip which didn’t work. Through trial and error I was able to at least get the endpoint on the Audiocodes to register with Asterisk pjsip. But now when I make a call to the extension/endpoint on the audiocodes it will make two quick beeps and then nothing. I see the audiocodes port light up so I know the audiocodes is answering but it won’t page. The strange thing is it works fine using chan_sip. I know this might required a configuration change on the audiocodes but support for that is minimal if not null as my support contract expired. Just hoping someone here has successfully been able to configure Asterisk 13 pjsip with an audiocodes fxs module and port.

Thanks!

We have been using Audiocodes with pjsip for a while now.You are right, support is very minimal with Audiocodes. Good luck with warranty too. We have about 10 units (MP-124) working great with pjsip. We are using realtime in our case.
They just are regular endpoints in Asterisk.

Here are my settings for an audiocode endpoint
pjsip show endpoint Relais-91

Endpoint: <Endpoint/CID…> <State…> <Channels.>
I/OAuth: <AuthId/UserName…>
Aor: <Aor…>
Contact: <Aor/ContactUri…> <Status…> <RTT(ms)…>
Transport: <TransportId…> <BindAddress…>
Identify: <Identify/Endpoint…>
Match: <ip/cidr…>
Channel: <ChannelId…> <State…> <Time(sec)>
Exten: <DialedExten…> CLCID: <ConnectedLineCID…>

Endpoint: Relais-91/4491 Not in use 0 of 3
OutAuth: Relais-91/Relais-91
InAuth: Relais-91/Relais-91
Aor: Relais-91 1
Contact: Relais-91/sip:Relais-91@xxx.xxx.xxx.xx:5060 Unknown nan
Transport: transport-udp udp 3 104 xxx.xxx.xxx.xx:5060

ParameterName : ParameterValue

100rel : yes
accountcode : garneau
aggregate_mwi : true
allow : (ulaw)
allow_subscribe : true
allow_transfer : true
aors : Relais-91
auth : Relais-91
call_group :
callerid : “Sci. Sociales” <4491>
callerid_privacy : allowed_not_screened
callerid_tag :
connected_line_method : invite
context : garneau-interne
cos_audio : 6
cos_video : 0
device_state_busy_at : 3
direct_media : true
direct_media_glare_mitigation : none
direct_media_method : invite
disable_direct_media_on_nat : true
dtls_ca_file :
dtls_ca_path :
dtls_cert_file :
dtls_cipher :
dtls_fingerprint : SHA-256
dtls_private_key :
dtls_rekey : 0
dtls_setup : active
dtls_verify : No
dtmf_mode : auto
fax_detect : false
force_avp : false
force_rport : true
from_domain : xxx.xxx.xxx.xx
from_user :
g726_non_standard : false
ice_support : false
identify_by : username
inband_progress : false
language : fr
mailboxes :
media_address :
media_encryption : no
media_encryption_optimistic : false
media_use_received_transport : false
message_context :
moh_suggest : default
mwi_from_user :
named_call_group :
named_pickup_group :
one_touch_recording : false
outbound_auth : Relais-91
outbound_proxy :
pickup_group :
record_off_feature : automixmon
record_on_feature : automixmon
rewrite_contact : false
rpid_immediate : false
rtp_engine : asterisk
rtp_ipv6 : false
rtp_keepalive : 0
rtp_symmetric : false
rtp_timeout : 0
rtp_timeout_hold : 0
sdp_owner : -
sdp_session : Asterisk
send_diversion : true
send_pai : true
send_rpid : true
set_var :
srtp_tag_32 : false
sub_min_expiry : 0
t38_udptl : false
t38_udptl_ec : none
t38_udptl_ipv6 : false
t38_udptl_maxdatagram : 400
t38_udptl_nat : false
timers : yes
timers_min_se : 90
timers_sess_expires : 1800
tone_zone : us
tos_audio : 184
tos_video : 0
transport : transport-udp
trust_id_inbound : false
trust_id_outbound : false
use_avpf : false
use_ptime : false
user_eq_phone : false

Appreciate everyone’s help. This particular paging system and Asterisk server is located at a remote office so I had to rely on a local contact to be my eye’s and ears. Unfortunately during our troubleshooting and multiple hours of me pulling my hair out wondering why it wasn’t working, it turns out that the amplifier was powered off. I need to put “check for power” at the top of my list for next time. thanks again everyone.

1 Like