AMI over TLS - tlsbindport invalid keyword & disable tcpbindaddr


#1

With TLS and AMI, I have two questions:

In manager.conf, I have the following set:

[general]
enabled = yes
displayconnects = no
tlsenable = yes
tlsbindport = 5039
tlsbindaddr = 10.0.9.95
tlscertfile = /tmp/public.pem
tlsprivatekey = /tmp/private.pem

which seems to be working, but when I reload manager through the CLI, it says that tlsbindport is an invalid keyword, yet if you run manager show settings, it grabs 5039 as the port…

astin04927*CLI> manager reload
[Apr 19 12:24:39] NOTICE[47743]: manager.c:8742 __init_manager: Invalid keyword <tlsbindport> = <5039> in manager.conf [general]
astin04927*CLI> manager show settings

Global Settings:
----------------
  Manager (AMI):             Yes
  Web Manager (AMI/HTTP):    No
  TCP Bindaddress:           [::]:5038
  HTTP Timeout (minutes):    60
  TLS Enable:                Yes
  TLS Bindaddress:           10.0.9.95:5039
  TLS Certfile:              /tmp/public.pem
  TLS Privatekey:            /tmp/private.pem
  TLS Cipher:
  Allow multiple login:      Yes
  Display connects:          No
  Timestamp events:          No
  Channel vars:
  Debug:                     No

The other question I have is - is there a way to disable TCP binding on 5038, as if I were to set enabled=no or is it that when TLS is enabled, TCP has to also be enabled? I’ve tried tcpbindaddr=disabled and other variants, but to no luck or avail.

Thanks,

Justin