Agent Login - Queues and Analog lines


#1

I am having aproblem with Agent Login and Queues. I have an extension for Agents to Login and it that part works. You can diall extension 1500, it will ask for Agent Login and Agent Password and all is working. I have 1 QUEUE setup as [tech] and have added the agents to the QUEUE.

Here is my problem, after the AGENT LOGS IN, I can see them LOGGED IN, but it shows them as unavailable?

I am thinking it’s because I only have single ANALOG LINE? I have seen in some documents it speaks about going offhook and then LOGIN, I have tried pressing the # key, but I get a message on the Asterisk Console that says the resource is busy?

Now if I change extension 1500 to AddQueueMember(tech), it works just fine when you dial it from an extension in the company.

So my question is this, can you have AGENT LOGIN working with just single analog lines, are does it need to be PRI?

Any help on understanding why agents show as unavailable would be great.

Thanks in advanced,

Cliff


#2

It should work just fine with only 1 analog line.

I dont know right away why they show up as unavailable.


#3

No matter what I do, the agents still show (unavailable)…?? Is there a certain version of Asterisk that I need to be on? I ahve used many of the sample config files online and copied them.

I am puzzled as to why I can login, it shows I’m Logged-In but yet it shows I’m unavailable.

Is there some special login procedure I need to be doing?

For example I have in my extension config:

1505 => AgentLogin()

I have tried AgentLogin(tech), AgentLogin(6000) for the agent ID… They all LOG me in, I still just show unavailable and I’m stumped>>>

Is there anything I need to do on the phones, I am using a SIP Softphone, Xten EYEYBEAM… Do you need to press any keys to go available???

LOST???