After a minute or two, cannot ring device

The devices are Siemens Openstage. When connected on the same network to an asterisk server (version 16), they work fine. When behind a NAT, connect fine to a telecom provider, also work fine.

But when I connect to an asterisk server (version 16) on a virtual server on the internet not behind a NAT (but device still is), works fine for a minute or two, and then any calls to the device don’t ring.


[office-phone](!)
type=endpoint
context=LocalSets

[Siemens-Openstage](!,office-phone)
disallow=all
allow=alaw
allow=ulaw
allow=g729

rtp_symmetric=yes
direct_media=no
rewrite_contact=yes

[auth-userpass](!)
type=auth
auth_type=userpass

[aor-single-reg](!)
type=aor
max_contacts=1
remove_existing=yes


...


[200serie](!,Siemens-Openstage)
; config for the series here
callerid=<31431111111>


[Set203](200serie)
auth=auth203
aors=Set203

[auth203](auth-userpass)
password=nunubiznz
username=Set203

[Set203](aor-single-reg)

Thanks in advance!

You haven’t configured a qualify_frequency, so Asterisk is not sending any OPTIONS request. This means that the NAT Mapping can close resulting in calls to the device to fail. The qualify_frequency option is set on the AOR[1]

[1] https://wiki.asterisk.org/wiki/display/AST/Asterisk+18+Configuration_res_pjsip#Asterisk18Configuration_res_pjsip-contact_qualify_frequency

Also you have symmetric media, and rewrite contact, but not the other NAT hack, force rport. That actually tends to suggest that the first two aren’t needed either.

The “force_rport” option defaults to “yes”, so it’s only needed to be specified if you want to disable it (ala Cisco phones).

Thank you so very much! That was it.