Additional parameter in "To" header

Hey guys. I would like your help. I need to direct DID numbers to a Voximplant server. They require that the “To” field of the header be sent in the following format:

user@serverip:port;vireg=xyz

my problem is in sending the vireg. I’ve tried every way and it won’t ship.

I’m using Asterisk 13.35 on the MagnusBillig platform.

I’m almost giving up. can anybody help me?

That’s invalid. Did you mean:

sip:user@serverip:port;vireg=xyz

Is vireg a uri-parameter or a to-param?

If it can be done at all, I think it will be:

Dial (pjsip/endpoint/sip:user@serverip:port\;vireg=xyz)

my server doesn’t use pjsip! ;(

Both chan_sip and your antediluvian version of Asterisk are EOL. You need to switch to chan_pjsip and a supported version of Asterisk.

You definitely can’t do what you want with chan_sip.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.