Adding pause in the middle of dialing


#1

Because of my setup (Using Asterisk with Toshiba DK system) I need to dial a 9 , then add a pause, then the rest of the number - I am not sure how to do this - do I use the “wait” function?

In other words dialing straight from the dialplan 915551244 is too fast for my toshiba

I need to dial: 9 (pause 2 seconds)15551234

Thanks for any help


#2

w is equal to a 100 millasecond delay.
if you wanted a 9 and then a wait for a little bit you can do
exten => _XXXXXXX,1,Dial(Zap/1/9www${EXTEN})
or

exten => _9XXXXXXX,1,Dial(zap/1/9www${EXTEN:1})

or whatever else floats your boat. :slight_smile:


#3

I tried it but I still get a problem. Just wondering if this “w” was introduced after asterisk came out initially. I am running on a very old asterisk version (well over a year old, using redhat 7.3) I really can’t tell if it is pausing or not.

Of course, my last resort is to upgrade everything - but right now I have Asterisk working the way I need it except for that.


#4

upgrade asterisk crazy… :slight_smile:


#5

Are you using a SIP device?


#6

Yes, I am testing with a Cisco and a SNOM - I tried it on another test machine with an updated asterisk on Fedora 3 and it works!

Except now, after 1 or 2 successful calls, my TDM400 Card starts to output an awful sound through the phone and doesn’t connect - I am really wondering if it is now a defective card. The only thing that fixes the horrible static sound is to reboot the machine and modprobe and ztfg - but sometimes it still happens right away after the reboot.

Boy but when it does connect, I get no echo and problem-free conversation !

Anyone ever had this horrible sound problem? — Help


#7

I have TDM11B Card from Digium, sometimes I lost the dialtone on the phone and sometimes I get like a static sound, I e-mailed Digium and they told me to do modprobe wctdm lowpower=1 but still I lost dialtone, they replaced the card twice but up to now I’m still experiencing the lost of dialtone.