A little help: when a**gic phone answer,ip phones still ring

I have set a PBX asterisk for home testing
i have 2 analogic phone connected on their fxs port
and 2 ip phones connected to pbx wich is connected to a fsx port.
When someone call,if i answer with ip phone,the analogic phone stop
ringin(and is ok),but if i answer with analogic phone the ip phone still ring.
My configuration

[mycontext]

exten => 200,1,Dial(dahdi/1/outgoing_number) // dial 200 to dialout from dahdi channel 1
exten => 200,1,Set(LANGUAGE()=it)
exten => 200,2,Hangup

exten => 1001,1,Dial(SIP/1001,10,t,m)
;exten => 1001,2,Voicemail(1001@mycontext)
exten => 1001,3,Hangup

exten => 1002,1,Dial(SIP/1002,10,t,r,m)
;exten => 1002,2,Voicemail(1002@mycontext)
exten => 1002,3,Hangup

exten => 1003,1,Dial(SIP/1003,10,t,r,m)
;exten => 1003,2,Voicemail(1003@mycontext)
exten => 1003,3,Hangup

exten => 7500,1,VoicemailMain(@mycontext)

exten => 600,1,Answer()
exten => 600,2,Playback(demo-echotest) ; Let them know what
exten => 600,3,Echo()                  ; Do the echo test
exten => 600,4,Playback(demo-echodone) ; Let them know it 
exten => 600,5,Hangup()

[from-pstn]
exten => s,1,Answer()
exten => s,2,Dial(SIP/1002&SIP/1001&dahdi/2,20,r,t,) 
exten => s,3,Voicemail(1002@mycontext)
exten => s,4,Hangup()

Ip phones are grandstream 1400
card is TDM410P
A little help?
Thanks

No way?
I never solved this :frowning:

My conf files

/etc/asterisk/chan_dahdi.conf

[code][trunkgroups]

[channels]
context=entrata
language=it
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=yes
faxdetect=incoming
echotraining=800
rxgain=0.0
txgain=0.0
callgroup=2
pickupgroup=2
immediate=no

;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes
busycount=6

#include /etc/asterisk/dahdi-channels.conf[/code]

extension.conf

[code]
[interni]
include => diamondcardterm
include => entrata

exten => 200,1,Dial(dahdi/4/outgoing_number) // dial 200 to dialout from dahdi channel 4
exten => 200,1,Set(LANGUAGE()=it)
exten => 200,2,Hangup

exten => 1001,1,Dial(SIP/1001,20,t,m)
;exten => 1001,2,Voicemail(1001@interni)
exten => 1001,3,Hangup

exten => 1002,1,Dial(SIP/1002,20,t,m)
;exten => 1002,2,Voicemail(1002@interni)
exten => 1002,3,Hangup

exten => 1003,1,Dial(SIP/1003,20,t,m)
;exten => 1003,2,Voicemail(1003@interni)
exten => 1003,3,Hangup

exten => 1004,1,Dial(SIP/1004,20,t,m)
;exten => 1004,2,Voicemail(1004@interni)
exten => 1004,3,Hangup

exten => 7500,1,VoicemailMain(@interni)

exten => 600,1,Answer()
exten => 600,2,Playback(demo-echotest) ; Let them know what
exten => 600,3,Echo() ; Do the echo test
exten => 600,4,Playback(demo-echodone) ; Let them know it
exten => 600,5,Hangup()

[entrata]
exten => s,1,Answer()
exten => s,2,GotoIf(${BLACKLIST()}?blacklisted)
exten => s,3,Dial(SIP/1003&SIP/1002&SIP/1001&dahdi/1,150,t,m)
;exten => s,3,Voicemail(1002@interni)
exten => s,4,Hangup()[/code]

The dial options are wrong, you put all in the same separtor like: exten =>…DIAL(blbalbal,20,tTxXwW)