4WTO extensions.conf

Q: How do I configure Asterisk to allow dial-into a 4WTO line. We have two 4WTO audio modules on our TDM network to allow listening. Operations wants to be able to dial into these lines to listen to radio traffic from simple FM radio receivers.
Asterisk is connected to the TDM channel bank via a Digium quad T1.
The computer that controls the TDM network automatically sets the T1 timeslot signaling to E&M No Signaling. I connected those timeslots to Dahdi timeslots 38 & 39 (2nd T1), configured likewise as E&M No Signaling.
(The first T1 is my connection to the Operations PBX, run by somebody else. This connection has been operational for several years.)
My problem is, Dahdi/Asterisk sees these two E&M lines as constantly off-hook and attempts to answer them, then times out, drops them, and answers them again in an endless loop.
Ergo, it’s almost impossible to dial into these two lines while they’re almost continuously off-hook.
Does anybody have recommendations how I can make the dialplan not answer automatically?

I’m not really a DAHDI guy, but you could try setting

immediate=no instead of immediate=yes and see if that helps?

1 Like

Thanks, John. Great idea but immediate=no is my default setting. I’ve never gained anything by setting it to “yes” and, with some of my crummy radio hops, “yes” is detrimental.

Bummer. I’m afraid that’s the only thing I could think of.